2012年3月16日

[vine-users:081705] Re:Ruby の最新版の導入は可能でしょうか

永井@知能.九工大です.

From: KATO Masashi <mkato@xxxxx>
Subject: [vine-users:081703] Re: Ruby の最新版の導入は可能でしょうか
Date: Thu, 15 Mar 2012 23:49:43 +0900
Message-ID: <20120315234943.dc9a98be.mkato@xxxxx>
>> Ruby 1.9.3-p125 がリリースされています。
>> Vine6.0にこの最新版のRubyを導入することは可能ですか?

>
> ruby は独立したアプリではなく言語処理系なので、1.8.7 系から 1.9.3 系への
> メジャーバージョンの更新となると、他のパッケージが影響を受ける可能性があ
> ります。

それは仰る通りなのですが,オフィシャルパッケージの 1.8 系 Ruby と
独自インストール版との共存は問題なく可能なはずですよね.

# 実際,私の手元の Vine6 環境上では共存させていますし.

オフィシャルの Ruby との共存をさせるのであれば,
/usr/local 下にインストールするようにして,
実行ファイルに suffix を付けておけばいいでしょう.
suffix なしの場合,実行ファイル検索順で /usr/local/bin/ruby が優先され,
オフィシャルの 1.8 系を想定しているスクリプトに支障が出るかもしれません.

Ruby の公式サイトから入手したソースによる導入であれば,
最初の configure の際に
$ ./configure --program-suffix=19
としておけば,実行ファイルは /usr/local/bin/ruby19 や
/usr/local/bin/irb19 などでインストールされるはずです.
ライブラリは /usr/local/lib/ruby/ 下となります.

コンパイルの際にエラーが多数出るということは,
必要とされているライブラリの devel パッケージが
単に導入されていないだけではないでしょうか.
もしそうなら,エラーが出ている部分で要求しているライブラリの
devel パッケージ (例えば readline なら readline-devel パッケージ) を
導入するだけでエラーは解消されるはずです.
--
永井 秀利 (nagai@xxxxx)
九州工業大学大学院情報工学研究院知能情報工学研究系知能情報メディア部門助教
_______________________________________________
vine-users mailing list
vine-users@xxxxx
http://listserv.linux.or.jp/mailman/listinfo/vine-users


投稿者 xml-rpc : 2012年3月16日 06:54
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/108948
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。