2012年1月16日

[vine-users:081658] Re:PHPのいくつかのモジュールを手に入れたい

彩草塗です。

かとうさん、ご教授ありがとうございます。

(2012/01/16 15:50), Tomohiro 'Tomo-p' KATO wrote:
>> 1:php-common
>> 2:php-cli
>> 4:php

>> 5:php-gd
>> 6:php-mbstring
>> 8:php-xml
>
>   上記の機能はphp5パッケージに含まれています。
>
>> 3:php-pdo
>
>   php5-pdoパッケージになります。
>
>> 7:php-mysql
>
>   php5-mysqlパッケージになります。

これらのモジュールは全てインストールしてありました。

>> /usr/lib/php5/pdo_firebird.so
>> /usr/lib/php5/pdo_dblib.so
>> /usr/lib/php5/pdo_oci.so
>
>   それぞれFirebird, MS SQL Server/Sybase, Oracleを使うためのモジュール
>  ですが、以下にあるphp5-mysqlを含め、基本的には全てが同時に必要になるこ
>  とはありません。自分がどのデータベースを用いるつもりなのか、により選択
>  してください。

OpenPNEは、mysqlを使うようです。
で、上記3つのファイルは、結局のところ必要ないようです。
なぜ、エラーを吐くのかを調べたところ、php.iniに以下の記述をしていたため
のようです。
extension=pdo_firebird.so
extension=pdo_dblib.so
extension=pdo_oci.so

必要無いようですので、コメントアウトしたところ、上記3つのファイルが無い
というエラーは無くなりました。

残念ながら、まだエラーが出て、OpenPNEの設定はうまく行きません。
しかし、そのエラーは、Vineに関連するエラーでは無いかも知れませんので、も
う少し調べてみます。

ありがとうございました。

--
彩草塗(CyksArt) dreum1958@xxxxx
http://www.geocities.jp/cyksart/
_______________________________________________
vine-users mailing list
vine-users@xxxxx
http://listserv.linux.or.jp/mailman/listinfo/vine-users


投稿者 xml-rpc : 2012年1月16日 23:40
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/108194
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。