2011年11月 4日

[vine-users:081554] Re:Vine linux 6.0でFontの設定がうまくいかない

喜多です。 釡江さんご返事ありがとうございます。
> % locale
>
locale というコマンドだったんですね。
> を試してみてください. あるいは, 環境変数 LANG を確認してみてください.
> % echo $LANG
> デフォルトだと, ja_JP.UTF-8 と表示されると思います.
> ja_JP.EUC-JP または C に変えてみるとどうでしょうか?

>
> グラフィカルログインを使用しているのであれば,
> メニューから選択できたように思います.
> あるいは setenv で設定してから起動してみてください.
>
さっそく試してみました。

% locale
LANG=ja_JP.utf8
LC_CTYPE="ja_JP.utf8"
LC_NUMERIC="ja_JP.utf8"
LC_TIME="ja_JP.utf8"
LC_COLLATE="ja_JP.utf8"
LC_MONETARY="ja_JP.utf8"
LC_MESSAGES="ja_JP.utf8"
LC_PAPER="ja_JP.utf8"
LC_NAME="ja_JP.utf8"
LC_ADDRESS="ja_JP.utf8"
LC_TELEPHONE="ja_JP.utf8"
LC_MEASUREMENT="ja_JP.utf8"
LC_IDENTIFICATION="ja_JP.utf8"
LC_ALL=

% setenv LANG ja_JP.eucjp
LANG=ja_JP.eucjp
LC_CTYPE="ja_JP.eucjp"
LC_NUMERIC="ja_JP.eucjp"
LC_TIME="ja_JP.eucjp"
LC_COLLATE="ja_JP.eucjp"
LC_MONETARY="ja_JP.eucjp"
LC_MESSAGES="ja_JP.eucjp"
LC_PAPER="ja_JP.eucjp"
LC_NAME="ja_JP.eucjp"
LC_ADDRESS="ja_JP.eucjp"
LC_TELEPHONE="ja_JP.eucjp"
LC_MEASUREMENT="ja_JP.eucjp"
LC_IDENTIFICATION="ja_JP.eucjp"
LC_ALL=

でも、echo $LANG では
ja_JP.UTF-8

と表示されます。なんでだろう?
端末のメニューの「端末」「文字コードの設定」から「euc_jp」を選択しても
echo $LANGはかわりませんでした。

めげずに、

% /usr/bin/xrdb -merge /home/acad18/Acad_vl # フォント設定Fileをマージ

Acad_vlの中身は

AdvanceCAD.Alphafont.Large: -vine-VL
PGothic-medium-r-normal--12-116-75-75-p-*-jisx0201.1976-0
AdvanceCAD.Alphafont.Medium: -vine-VL
PGothic-medium-r-normal--10-96-75-75-p-*-jisx0201.1976-0
AdvanceCAD.Alphafont.Small: -vine-VL
PGothic-medium-r-normal--0-0-0-0-p-0-jisx0201.1976-0
AdvanceCAD.Kanjifont.Large: -vine-VL
PGothic-medium-r-normal--12-116-75-75-p-*-jisx0208.1983-0
AdvanceCAD.Kanjifont.Medium: -vine-VL
PGothic-medium-r-normal--10-96-75-75-p-*-jisx0208.1983-0
AdvanceCAD.Kanjifont.Small: -vine-VL
PGothic-medium-r-normal--0-0-0-0-p-0-jisx0208.1983-0

です。ちなみに、このフォント設定で Vine Linux 4.2上では Advance Cad は
起動してます。

% /home/acad18/exe/acad.exe =1275x1020+0+0 # Advance Cad 起動
No X resource is defined for font.1
Or invalid X resource is defined for font. # 起動せず

# xfd も試してみました。

% xfd -fn "-vine-VL
PGothic-medium-r-normal--12-116-75-75-p-*-iso10646-1" # 起動しました

% xfd -fn "-vine-VL
PGothic-medium-r-normal--12-116-75-75-p-*-jisx0208.1983-0"
Warning: Missing charsets in String to FontSet conversion
Warning: Unable to load any usable fontset
Warning: Cannot convert string "-vine-VL
PGothic-medium-r-normal--12-116-75-75-p-*-jisx0208.1983-0" to type
FontStruct
xfd: no font to display # 起動せず

やっぱり echo $LANG で ja_JP.UTF-8 となるのがおかしいのでしょうか。

# Vine Linux Ver4.2で, LANGをutf8にしたらどうなるかを試してみました。

% setenv LANG ja_JP.utf8
% locale
LANG=ja_JP.utf8
LC_CTYPE="ja_JP.utf8"
LC_NUMERIC="ja_JP.utf8"
LC_TIME="ja_JP.utf8"
LC_COLLATE="ja_JP.utf8"
LC_MONETARY="ja_JP.utf8"
LC_MESSAGES="ja_JP.utf8"
LC_PAPER="ja_JP.utf8"
LC_NAME="ja_JP.utf8"
LC_ADDRESS="ja_JP.utf8"
LC_TELEPHONE="ja_JP.utf8"
LC_MEASUREMENT="ja_JP.utf8"
LC_IDENTIFICATION="ja_JP.utf8"
LC_ALL=

% echo $LANG
ja_JP.utf8

% ac18 # Advance Cad起動スクリプト

cadはちゃんと起動しましたが、漢字入力はできませんでした。
終了後の端末の画面には

XCreateFontSet falied.

と出ていました。
「文字コードを一時的にでも eucjp にすることは必要だが、それだけでは起動
しない。」
と、言うことでしょうか?

申し訳ありせんが、またアドバイスをよろしくお願いします。

喜多

_______________________________________________
vine-users mailing list
vine-users@xxxxx
http://listserv.linux.or.jp/mailman/listinfo/vine-users


投稿者 xml-rpc : 2011年11月 4日 13:37
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/107203
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。