2011年9月 4日

[vine-users:081368]mod_perl をインストールすると、Apache httpd が起動出来なくなりました。

こんにちは、こちらはやんちです。

■mod_perl をインストールすると、Apache httpd が起動出来なくなりました。

# /etc/init.d/apache2 restart
Apache2 HTTP Serverを停止中: [ OK ]
Apache2 HTTP Serverを起動中: apache2: Syntax error on line 209 of
/etc/apache2/conf/apache2.conf: Syntax error on line 10 of

/etc/apache2/conf.d/perl.conf: Cannot load
/etc/apache2/modules/mod_perl.so into server: libperl.so: cannot open
shared object file: No such file or directory
[ 失敗 ]
#

こんな感じ。

mod_perl のインストールは apt 経由で、
# apt-get install mod_perl
としました。
こちらは成功。

(´・ω・`)しょぼん

●環境
# uname -a
Linux localhost.localdomain 2.6.35-20vl6 #1 SMP Tue Jul 5 23:51:21 JST
2011 i686 i686 i386 GNU/Linux
# cat /etc/vine-release
Vine Linux 6.0 (Haut Brion)
#

●perl はインストール済みの様です。
# rpm -qa | grep perl-5
perl-libwww-perl-5.833-3vl6.noarch
perl-5.12.3-3vl6.i686
#

●libperl も入っている様です。
# find /usr/ -name "libperl.so" -print
/usr/lib/perl5/5.12.3/i386-linux-thread-multi/CORE/libperl.so
#

後、何を確認すれば、良いでしょうか?
情報をお持ちの方がおられましたら、返信お願いします。

--
Kenji Yamamichi <yanch@xxxxx>

_______________________________________________
vine-users mailing list
vine-users@xxxxx
http://listserv.linux.or.jp/mailman/listinfo/vine-users


投稿者 xml-rpc : 2011年9月 4日 21:48
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/106164
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。