2009年9月20日

[vine-users:079668] Re: ipw2200 がmodprobe できない

おかもと@G です。

On Sat, 19 Sep 2009 12:05:38 +0900, 田添 一哉 wrote:
>  再導入後、無線 LAN (IntelProWireless 2915)が利用できなくなりました。エ
> ラーメッセージは下記の通りです。
> ------------------------------------------------------
> [root@xxxxx ~]# modprobe ipw2200
> FATAL: Error inserting ipw2200

> (/lib/modules/2.6.27-43vl5/extra/drivers/net/wireless/ipw2x00/ipw2200.ko):
> Invalid module format
> ------------------------------------------------------

というエラーメッセージに戻って考えると、

On Sat, 19 Sep 2009 22:28:16 +0900, 長南洋一 wrote:
> もし、ipw2200.ko がご自分でインストールしたものだったら、カーネルと
> 合っていないというのが、まず頭に浮かぶことですけれど。

しか思い浮かびませんが。

On Sun, 20 Sep 2009 08:39:49 +0900, 長南洋一 wrote:
>> [root@xxxxx ~]# locate ipw2200.ko
>> /lib/modules/2.6.27-43vl5/kernel/drivers/net/wireless/ipw2200.ko
>> /lib/modules/2.6.27-43vl5/extra/drivers/net/wireless/ipw2x00/ipw2200.ko
>
> 両方とも実ファイルですか。下の方は、なんというパッケージから
> 来たのか。rpm -qf でお調べになったら、どんな結果が出るでしょう。

田添さんのところと同じように、私の環境でも2つのipw2200.ko が出てきましたが、

前者は、kernel-2.6.27-43vl5、
後者は、kernel-module-compat-wireless-0.20090630_2.6.27_43vl5-2vl5

からでした。ということは、なぜか 64bit 版をインストールしたのに、
modprobe は32bit 版の ipw2200.ko をロードしようとした、ということでしょ
うか。

確認ですが、lsmod には、ipw2200 は出ていないのですね?

もし、 64bit 版をインストールされていて、lsmod に ipw2200 がないのなら、
kernel-module-compat-wireless-0.20090630_2.6.27_43vl5-2vl5 を削除して
から、modprobe をするとどうなるでしょうか?

---
Okamoto, Junji


投稿者 xml-rpc : 2009年9月20日 20:40
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/88778
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。