2009年9月16日

[vine-users:079640] Re: ghc6のインストール

高瀬です.

> xmonadを試したくて、
> ghc6をインストールする所でハマっています。

強引ですが,別のディストリビューション用のRPMがVine4.2でも動きます.
xmonadをコンパイルできるかどうかは分かりません.ghc6のバージョンも少し古いです.

公式サイトの http://www.haskell.org/ghc/dist/6.6/FC5rpms/ にある
次の2つのファイルをダウンロードして,下のようにインストールしたことがあります.
学習用の小さいHaskellプログラムなら,これでコンパイル・実行できていました.

http://www.haskell.org/ghc/dist/6.6/FC5rpms/ghc-6.6-1.i386.rpm
http://www.haskell.org/ghc/dist/6.6/FC5rpms/ghc66-6.6-1.i386.rpm

# rpm -ivh ghc-6.6-1.i386.rpm ghc66-6.6-1.i386.rpm

>
> virtualboxに
> Vine Linux 4.2 (Lynch Bagaes)
> Kernel 2.6.16-76.51vl4 on an i686
> の最小構成でインストールしています。
>

環境は同じく
Vine Linux 4.2 (Lynch Bagaes)
Kernel 2.6.16-76.51vl4 on an i686
です.

このRPMの依存情報を見ると下記のものが必要ですが,
これらは全てVineのRPMがあります.
gmp-devel
ncurses
readline-devel
perl

-------------------------------------------------------------------------
高瀬竜一 <r-takase@xxxxx>

独立行政法人 産業技術総合研究所
知能システム研究部門 タスクビジョン研究グループ
-------------------------------------------------------------------------

投稿者 xml-rpc : 2009年9月16日 07:32
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/88620
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。