2009年6月28日

[vine-users:079358] apache2 をソースからインストールでエラー

vine4.2インストール後以下の手順でLAMPを構築したところ、Apache2
のインストール時に、
checking for zlib location... not found
checking whether to enable mod_deflate... configure:
error: mod_deflate has been

requested but can not be built due to prerequisite
failures

というエラーが生じて、行き詰ってしました。

Mysql,Apache2はソースコードからインストールしました。

手順は以下の通りです。
1.mysql-5.1.35をインストール
rootでログインできることを確認
2.プリインストールされていたapache2をアンインストール
[root@xxxxx root]# apt-get --purge remove apache2
[root@xxxxx root]# find / -name apache*
/etc/apache2
/usr/share/icons/gnome/24x24/apps/apacheconf.png
/usr/share/icons/gnome/48x48/apps/apacheconf.png
/usr/share/icons/gnome/32x32/apps/apacheconf.png
/usr/share/vim/vim64/syntax/apache.vim
/usr/share/vim/vim64/syntax/apachestyle.vim
/usr/share/namazu/filter/apachecache.pl
/var/log/apache2
/var/www/manual/programs/apachectl.html
/var/www/manual/programs/apachectl.html.ko.euc-kr
/var/www/manual/programs/apachectl.html.en
/var/www/manual/images/apache_header.gif
[root@xxxxx root]#
3.httpd-2.2.11をインストール
[ ]# tar xvfz httpd-2.2.11.tar.gz
[ ]# cd httpd-2.2.11/
[ ]# ./configure --enable-module=all
--enable-mods-shared=all

checking whether to enable mod_deflate... checking
dependencies
checking for zlib location... not found
checking whether to enable mod_deflate... configure:
error: mod_deflate has been

requested but can not be built due to prerequisite
failures

checking for zlib location... not found
checking whether to enable mod_deflate... configure:
error: mod_deflate has been

requested but can not be built due to prerequisite
failures
エラーが発生

[ ]# find / -name zlib
/usr/src/kernels/2.6.16-0vl76.27-i686/include/config/zlib

[root@xxxxx root]# apt-get install zlib-devel
パッケージが無い。
[root@xxxxx root]# apt-get install zlib
インストールされている。

[ ]# tar xvfz httpd-2.2.11.tar.gz
[ ]# cd httpd-2.2.11/
[ ]# ./configure
config.status: creating build/pkg/pkginfo
config.status: creating build/config_vars.sh
config.status: creating include/ap_config_auto.h
config.status: executing default commands
[root@xxxxx httpd-2.2.11]#
エラーは表示されずに終了する。

[ ]# ./configure --enable-module=all
--enable-mods-shared=all
でエラーを生じさせずにインストールするにはどのようにすれ
ば宜しいのでしょうか?
ご教授願います。


投稿者 xml-rpc : 2009年6月28日 22:43
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/86250
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。