2009年3月31日

[vine-users:079279] Re: xmms-aac のインストール

長南です。ちょっと後片付けをしておきます。

daydreamer さんのメールより [vine-users:079278]
>
> > …… 同じバージョンのパッケージを上書き
> > インストールする方法をお尋ねなのですね。それなら、こんなふうにします。
> >
> > rpm -Uvh --replacepkgs faad2-2.6.1-2vl4.i386.rpm

> >
>
>  やってみましたが、またエラーが出ました。
>
> # rpm -Uvh --replacepkgs faad2-2.6.1-2vl4.i386.rpm
> 準備中... ###########################################
> [100%]
> ファイル /usr/bin/faad (パッケージ faad2-2.6.1-2vl4 から) は、
> パッケージ faad2-2.6.1-2vl4 からのファイルと競合しています。

それでは、

rpm -Uvh --replacepkgs --replacefiles faad2-2.6.1-2vl4.i386.rpm

でも、fadd2 はすでに新しくなっているのですから、こんなことを
やる必要はありませんし、どうしてもやりたい場合は、faad2 を
アンインストールしてから、インストールし直した方が気持ちがよいですね。


ところで、rhythmbox で aac ファイルを演奏しようとして、いろいろ試して
みましたが、どうやら Vine 4.2 では難しいようです。

要するに、gstreamer-0.10-plugins-bad をインストールすればよいらしい
のですが、うまく行きません。plugins-bad の新し目のバージョンだと、
Vine 4.2 の gstreamer が古くて configure で失敗します。
plugins-bad の古いバージョンを選ぶと、今度はどうやら faad2 が
新しすぎるらしく、libgstfaad.so が作れません。

gstreamer が新しけりゃいいんでしょ。だったら、と、gstreamer、
gstreamer-plugins-base、gstreamer-plugins-good のソースパッケージを
Seed から持ってきて rpmbuild --rebuild なんてこともやってみましたが、
gstreamer-plugins-base 作成中に gtk2-devel >= 2.12.0 が必要だと
言われて、rebuild に失敗しました。

わたしとしてはあきらめて、Vine 5.0 を待つことにします。

# うちの場合、gstreamer08 とか gstreamer08-plugins-extra-audio
# といったパッケージも入っていて、後者には libgstfaad.so があったり
# するのですが、こういったパッケージは何かの役に立っているんでしょうか。

--
長南洋一


投稿者 xml-rpc : 2009年3月31日 15:48
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/83795
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。