2009年2月 5日

[vine-users:079164] Re: NVIDIAドライバでの設定

高瀬@つくばです.

On Thu, 5 Feb 2009 19:52:27 +0900
kazu yamamoto <nami@xxxxx> wrote:

>  当方、vineではないのですが、plamo上でGF8600GTを使用しています。
> kernel 2.6.26系の時は、173.14でした。
> kernel 2.6.27系にアップしたところ、

> kernel moduleがコンパイルできなくなってしまったので、180.22 へアップしました。
> 今のところ180.22による不具合は、発生していません。

もしよろしければ,plamo上のコマンドラインで

$ getconf GNU_LIBPTHREAD_VERSION

を実行して,NPTLと返ってくるかどうか教えてください.
Vine4.2では"linuxthreads-0.10"と表示されます.


以前の記事[vine-users:078810] に書いた通り,
NVIDIAドライバの173以降では,LinuxThreadsを使用するpthreadライブラリを
リンクしたOpenGLアプリケーションが,動作しないのではないかと私は疑っています.

なお,その記事で環境変数LD_ASSUME_KERNELを"2.4.0"に設定すれば
新しいNVIDIAドライバでアプリケーションが動作すると書きましたが,
グラフィック描画のパフォーマンスが極端に落ちることに気が付いていませんでした.
Vineのカーネルのバージョンが上がるまで,NVIDIAドライバは169.xを使う方が良いでしょう.

-----------------------------------------------------------------
高瀬竜一 <r-takase@xxxxx>
独立行政法人 産業技術総合研究所
知能システム研究部門 3次元視覚システム研究グループ
-----------------------------------------------------------------

投稿者 xml-rpc : 2009年2月 5日 20:34
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/81955
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。