2009年1月21日

[vine-users:079106] Re: vlc-0.9.8a のビルド(追伸)

畑です。

vlc-0.9.8aでmpeg-1/mpeg-2が再生できない問題が解決せず、結局Ubuntu8.04で動作を確認
したvlc-0.8.6eをビルドしてうまくいきましたので参考までに報告します。

ちなみにUbuntu8.10にエントリーされているvlc-0.9.4も、当方では画面のちらつきなどの
不具合が発生するようです。

vlc-0.8.6ダウンロード先は以下です。
http://download.videolan.org/pub/videolan/vlc/0.8.6e/vlc-0.8.6e.tar.bz2

インストール手順は0.9.8aとほぼ同様です。

# apt-get install self-build-ffmpeg
# apt-get install libmad-devel ← 追加
# apt-get install fribidi-devel
# apt-get install libgcrypt-devel
# apt-get install wx-gtk2-devel ← 追加

次に以下をダウンロードしてlibmpeg2 をインストールします。
http://libmpeg2.sourceforge.net/files/libmpeg2-0.5.1.tar.gz

$ tar -xvzf libmpeg2-0.5.1.tar.gz
$ cd libmpeg2-0.5.1
$ ./configure --prefix=/usr
$ make
# checkinstall

その後、vlc-0.9.8aと同じ手順でビルドします。
$ tar -zxvf vlc-0.8.6e.tar.bz2
$ cd vlc-0.8.6e
$ ./configure --prefix=/usr --disable-dbus --disable-libv4l2 --disable-v4l2
$ make
# checkinstall(または make install)

では


--------------------------------------
Power up the Internet with Yahoo! Toolbar.
http://pr.mail.yahoo.co.jp/toolbar/


投稿者 xml-rpc : 2009年1月21日 19:03
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/81278
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。