2009年1月17日

[vine-users:079098] Re: vlc-0.9.8a のビルド

鈴木さん、どうもありがとうございました。
畑です。

> コマンドインターフェースだけでよければ、
> gcc4 と、qt4 は不要で、
> # apt-get install self-build-ffmpeg
> # apt-get install fribidi-devel
> # apt-get install libgcrypt-devel

> $ tar -zxvf vlc-0.9.8a.tar.bz2
> $ cd vlc-0.9.8a
> $ ./configure --prefix=/usr --disable-dbus --disable-qt4 --disable-skins2
> --disable-libv4l2 --disable-v4l2
> $ make
> # make install
>
> でコンパイルと起動までは確認しました。

非常にタフなビルドでしたが、当方に不足するpackageを追加しながら上記インストラクシ
ョンに --disable-glxを追加して、コマンドインターフェースをビルドすることができま
した。
一部のmpgは avcodec decoder error: more than 5 seconds of late video -> dropping
frame (computer too slow ?)
となって起動できなかったものの、その他のダウンロードしたflv,wmv,asfなどはほぼ問題
なく再生できました。

さらに進めるため以下是非ご教示いただきたくよろしくお願いします。

1)当方のaptでglxは最新版がインストールされており、apt-cache seach glxで関係ありそ
うなパッケージ(とそのdevel)をapt-getしましたがだめでした。やむなく、
--disable-glxを指定しました。glxを可能にする方法をご教示ください。

2)是非gui版をビルドしたいのですが、
#apt-get install qt4-develが取得できませんでした。これは当方のaptの設定がdefault
のままでVineSeedのpackageが取得できないためと思われますが、VineSeedをapt-getする
方法をご教示ください・

以上よろしくおお願いします。
ありがとうございました。


--------------------------------------
Power up the Internet with Yahoo! Toolbar.
http://pr.mail.yahoo.co.jp/toolbar/


投稿者 xml-rpc : 2009年1月17日 15:18
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/81127
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。