2008年9月26日

[vine-users:078830] Re: Firefoxでの画像表示がおかしい

あらいです。

In <873ajncdaz.wl%nomiya@xxxxx>;
野宮 賢 / NOMIYA Masaru <nomiya@xxxxx> wrote
as Subject "[vine-users:078823] Re: Firefox での画像表示がおかしい":

> 野宮です.

> つまり,/usr/lib/libGL.so.1.0.8762 は,fglrx の物だと思います.

> と,いうことで,あらいさんの場合は,インストール/アンインストールを繰り返し
> ている内におかしくなったのだと思います.

 ATI のドライバをアンインストールした状態で libGL.so.1 のリンク先ファ
イルがどのパッケージに属しているのか調べてみました。

$ rpm -q -f /usr/lib/libGL.so.1.0.8762
ファイル /usr/lib/libGL.so.1.0.8762 はどのパッケージにも属していません。

 確かにこれがドライバ由来のもののようですね。
 また、XOrg-gl を再インストールしても、このファイルがここにあると
libGL.so.1 のリンク先はこれになります。
 というわけで、次のことをやってみました。

・libGL.so.1.0.08762 を別ディレクトリに移して XOrg-gl 再インストール

# ls -l libGL.so.1
lrwxrwxrwx 1 root root 32 9月26日 22:04 libGL.so.1 -> ../../usr/X11R6/lib/libGL.so.1.2*

 これが本来の状態のような気がします。

・この状態で ATI のドライバインストール
 前のメールと同じ。aticonfig でエラー。
 /usr/X11R6/lib に libGL.so* でそれっぽいファイルはない。libGL.so.1.2
は日付が新しくなっている。

・ちょっといたずら
 ドライバをインストールした状態で、libGL.so.1 のリンク先を、
libGL.so.1.0.08762 にして aticonfig したら、見た目は正常に終了した。
 が、古いドライバをインストールしたときのように、KDE が立ち上がらなく
なった。

・ATI のドライバアンインストール

# ls -l /usr/lib/libGL.so.1
ls: /usr/lib/libGL.so.1: そのようなファイルやディレクトリはありません
# rpm -V XOrg-gl
/usr/lib/libGL.so.1 が見つかりません。

 libGL.so.1 がなくなった。XOrg-gl 再インストールで復旧。

 ……というような感じです。

In <48DCDEA2.6040001@xxxxx>;
Hiroshi Suzuki <setter@xxxxx> wrote
as Subject "[vine-users:078827] Re: Firefox での画像表示がおかしい":

> 鈴木です。

> 私のところは、Radeon 9600 なのですが、
> ati-driver-installer-8.40.4-x86.x86_64.run
> までは、動きました。

 別のメールで書きましたが、ati-driver-installer-8.39.4-x86.x86_64.run
はだめでした。9550 はもっと古いのでないと駄目かも?

In <871vz7ca7z.wl%nomiya@xxxxx>;
野宮 賢 / NOMIYA Masaru <nomiya@xxxxx> wrote
as Subject "[vine-users:078828] Re: Firefox での画像表示がおかしい":

> # rpm -qf /usr/X11R6/lib/libGL.so.1.2
>
> とした時の戻り値はどうなっています?

In <87zllvauqq.wl%nomiya@xxxxx>;
野宮 賢 / NOMIYA Masaru <nomiya@xxxxx> wrote
as Subject "[vine-users:078829] Re: Firefox での画像表示がおかしい":

> にある Xorg 由来の libGL.so.* を書き換えることはありません.

 参考までに私のところのを。まず何もしてない状態。

# rpm -V XOrg-gl
(何も出力されず)
$ rpm -q -f /usr/X11R6/lib/libGL.so.1.2
XOrg-gl-6.9.0-38.2vl4

 ドライバインストール後。

# rpm -V XOrg-gl
....L... /usr/X11R6/lib/libGL.so.1
SM5....T /usr/X11R6/lib/libGL.so.1.2
....L... /usr/lib/libGL.so.1
$ rpm -q -f /usr/X11R6/lib/libGL.so.1.2
XOrg-gl-6.9.0-38.2vl4


投稿者 xml-rpc : 2008年9月26日 22:52
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/77620
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。