2008年9月26日

[vine-users:078827] Re: Firefox での画像表示がおかしい

鈴木です。

# 横からすいません。

私のところは、Radeon 9600 なのですが、
ati-driver-installer-8.40.4-x86.x86_64.run
までは、動きました。
ちなみに、

/usr/lib/libGL.so.1 -> /usr/X11R6/lib/libGL.so.1.2
783362 /usr/X11R6/lib/libGL.so.1.2
となっています。
ati-driver-installer-8.41.7-x86.x86_64.run
以降にすると、kde は動かなくなります。
libGL.so.1 をロードするところで
"cannot handle TLS data" になってしまいます。
# 試しに、export LD_PRELOAD="/usr/lib/libstdc++.so.6 /usr/X11R6/lib/libGL.so.1"
# とかやってみたんですけど。

また、
Radeon 9200 SE なマシンでは、
ati-driver-installer-8.28.8.run
までが動くのは確認しています。
こちらは、
/usr/lib/libGL.so.1 -> /usr/X11R6/lib/libGL.so.1.2
854474 /usr/X11R6/lib/libGL.so.1.2
のようになっています。

で、
getconf GNU_LIBPTHREAD_VERSION
が linuxthreads じゃなくて、NPTL じゃないとダメなのかな?
と思っているのですが、
"cannot handle TLS data" の意味するところがどうもはっきりとわかってません。

参照: http://bugs.gentoo.org/show_bug.cgi?id=64927

--
Hiroshi Suzuki It's crucial qp
setter AT i-red DOT info to my (..)/
http://my.reset.jp/~setter/ Well-being - -
http://i-red.info/ ~~
Powered by Linux/DeleGate _____________*-_____

投稿者 xml-rpc : 2008年9月26日 22:07
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/77617
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。