2008年9月26日

[vine-users:078820] Re: Firefoxでの画像表示がおかしい

あらいです。

In <87abdvpb36.wl%nomiya@xxxxx>;
野宮 賢 / NOMIYA Masaru <nomiya@xxxxx> wrote
as Subject "[vine-users:078819] Re: Firefox での画像表示がおかしい":

> 野宮です.

> いや,"cannot hanle TLS data" というのは,libGL.so.1 絡みで出ていませんか?

 そうなんですが、実際には環境の問題で出てるのかと思いまして。事例を見
ると、色々なライプラリで出てるので。それに、TLS ですし。

> 考え得る方策は,
>
> 1. libGL.so.1 を含むパッケージを update する
>
> 若しくは,
>
> 2. libGL.so.1 を libGL.so.1 を libGL.so.1.orig と rename して ATI の
> Driver をインストールする
>
> といったところでしょうか?

 最新のドライバのインストールについて、再度実行してみました。1. は、ド
ライバのインストール時に変わっていると思うので、確認のみ。

・まず、現在 ATI のドライバがないことを確認。

$ ls -l /usr/share/ati
/bin/ls: /usr/share/ati: そのようなファイルやディレクトリはありません

・次に、念のため XOrg-gl を再インストール。

$ rpm -q -f /usr/lib/libGL.so.1
XOrg-gl-6.9.0-38.2vl4

# apt-get update
(略)

# apt-get --reinstall install XOrg-gl
(略)

・libGL.so.1 の実体を確認。

# ls -l /usr/lib/libGL.so.1
lrwxrwxrwx 1 root root 17 9月26日 19:12 /usr/lib/libGL.so.1 -> libGL.so.1.0.8762*

・ドライバをインストール。

# sh ./ati-driver-installer-8-9-x86.x86_64.run
(略)

"Install Driver 8.532 on X.Org 6.9.x"
"Automatic"
を選択。

・libGL.so.1 の実体を確認。入れ替わっている。

# ls -l /usr/lib/libGL.so.1
lrwxrwxrwx 1 root root 27 9月26日 19:15 /usr/lib/libGL.so.1 -> /usr/X11R6/lib/libGL.so.1.2

・aticonfig を実行。

# /usr/X11R6/bin/aticonfig --initial
/usr/X11R6/bin/aticonfig: error while loading shared libraries: libGL.so.1: cannot handle TLS data

……といった感じになりました。


・お掃除

# cd /usr/share/ati
# sh fglrx-uninstall.sh
restore of system environment completed
Uninstall fglrx driver complete...


投稿者 xml-rpc : 2008年9月26日 19:33
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/77609
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。