2008年9月24日

[vine-users:078778] Re: firefox3 印刷プレビューの挙動について

芳賀です。
アドバイスいただき、ありがとうございます。

On Wed, 24 Sep 2008 12:33:28 +0900
加藤 雅 <mkato@xxxxx> wrote:

| 近頃、グラフィックドライバ依存でエラーを起こすアプリがあることに気付き、

| で、今回は、自分の環境では田中さん同様不具合は発生しなかったのですが、逆
| も又真なりかもと、ドライバを入れ替えて試してみたら、御指摘の画像部分が印
| 刷プレビュー画面上で見事に真っ黒になりました。

| グラフィックチップは GeForce FX 5200、
| 不具合が再現したドライバは、X 付属の nv ドライバ、
| 正常に表示されたドライバは共に NVIDIA 社製の
| NVIDIA-Linux-x86-169.12
| NVIDIA-Linux-x86-173.14.12 ← (なぜか自環境では QT アプリは全滅)
| です。

| 芳賀さんの場合に当て嵌まるかどうかは不明ですが、一応そちら(グラフィック
| ドライバ)の方も疑ってみられては如何でしょうか?

ハードウェアとかドライバ関係は不得手なのですが、/var/log/Xorg.0.log に
よると、当方のグラフィックドライバは、

(--) PCI:*(1:0:0) Matrox Graphics, Inc. MGA G200 AGP rev 3

となっていて、以下がロードされているドライバなのではないかと思います。
てことは、X 付属のドライバということになりますか。加藤さんが確認され
た内容から推して、このドライバが怪しそうですね。

(II) LoadModule: "mga"
(II) Loading /usr/X11R6/lib/modules/drivers/mga_drv.so
(II) Module mga: vendor="X.Org Foundation"
compiled for 6.9.0, module version = 1.2.1
Module class: X.Org Video Driver
ABI class: X.Org Video Driver, version 0.8

また、以下のメッセージも出ていました。

(--) Chipset mgag200 found

ということは、対応策としては、
1) メーカー製の linux 用ドライバがあれば、それを試す。
2) X.org のもっと新しいバージョンなら解決するかもしれない。
の二つがありそうですね。

なお、余談ですが、(御存じの方が多いのかもしれませんが)、
http://kmuto.jp/debian/hcl/
というサイトがあり、"lspci -n" の出力をテキストフィールド内に
カットアンドペーストして、"check" ボタンを押すと、情報を分か
りやすく表示してくれました。おかげで、自分のグラフィックチッ
プがどういうものか分かりました。
--芳賀


投稿者 xml-rpc : 2008年9月24日 14:30
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/77453
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。