2008年7月 6日

[vine-users:078554] Re: 印刷ができなくなりました

長南です。

添付なさった error.log をざっと見てみました。おそらく問題が起きて
いるのは 209 行目でしょう。「PPD file is broken」と言われても、Avasys が
配布しているのを変更せずにお使いなんだろうし、ついこの間までこの PPD
ファイルでちゃんと印刷できていたんだろうし、わけがわかりませんけれど。

それでも一応は、/etc/cups/ppd 以下の ppd ファイルと /usr/share/cups

/model/ekpm930c.ppd(これを使っていると考えてよいのですね)の diff を
取ってみた方がよいかもしれません。

で、error_log の 209 - 210 行目は、

> D [05/Jul/2008:21:11:52 +0900] [Job 15] PPD file is broken. Cannot get option of PIPS.gs_mgl_e.ps 80 1739312 426361 1602852 319126 true 927 4 <0>
> E [05/Jul/2008:21:11:52 +0900] PID 13955 stopped with status 1!

ここからあとは、処理がループしているような気がします。

サカイさんのメールより [vine-users:078552]
>
> lpr なんとか.ps ---> 印刷できました。
> lpr かんとか.txt ---> ダメ
> lpr -Pプリンタ名 なんとか.ps ---> 印刷できました。
> OpenOffice や firefox から ---> ダメ

firefox からというのは、お試しになりましたか。
「mpage なんとか.txt | lpr」も試していただくべきでした。

# なんとか.txt は日本語の入ったプレーンテキスト。

それから、ダメにもいろいろあります。文字化けとか、白紙の排出とか、
まったくの無反応とか。そのへんはどうだったのですか。

> ということは,txtファイルやOpenOffice.orgのファイルを
> psファイルに変換するところでつまづいているということでしょうか。

ええ、そうかもしれません。あるいは、OpenOffice が作った PS 形式の
データを pips なり gs なりがうまく処理できないのかもしれません。

# OpenOffice における「プリンタの設定」は大丈夫そうですか、と一応
# うかがっておきます。

「Vine 4.0、Vine 4.2、ubuntu をクリーンインストール」なさったそう
ですが、今現在それぞれの cups gs OpenOffice のバージョンはどうなって
いますか。こうしたパッケージのバージョンがすべて Vine 4.0 公開当時の
ものに揃っていれば、印刷できてもよさそうに思うんですが。

本家の OOo を入れてしまったらどうだろうとも、ちょっと考えています。
Vine の OOo は Vine 4.0 公開以来 upgrade していないようなので、
OOo を変えても、意味がなさそうですけれど。

--
長南洋一


投稿者 xml-rpc : 2008年7月 6日 13:19
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/75009
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。