2007年12月29日

[vine-users:077927] Re: XWindowが、立ち上がらない

宮脇です。
長南さん、いつもありがとうございます。

> Vine 4.2 はクリーンインストールなんでしょうね。前の PC で Vine を
> 4.1 から 4.2 にアップグレードした上で、そのハードディスクを新しい
> PC に移したということも考えられますけれど。
まさにおっしゃるように、vine4.1 から 4.2 にアップグレードした上で、その
ハードディスクを新しいPCに移したのです。それで、このような問題が出たと

思います。vine4.2をクリーンインストールしておけば、インストール時に
Xwindowの設定がなされますので、もう少しうまく行ったかも知れません。

> おっしゃっていることがよくわかりません。「Checking for new hardware」
> というのは、ブート時に /etc/rc.d/init.d/kudzu が出すメッセージ
> でしょう。kudzu がビデオカードを見つけて、その結果 Xconfigurator が
> 起動されるのですか。そして、X のテストで失敗するということですか。
おっしゃるように、vine起動時にkudzuが出すメッセージでXconfiguratorが
起動するのですが、Xのテスト(設定)で失敗するということです。

> テキスト・ログインはできるんですね。
テキストログインはできましたので、Xの設定をやってみたのですが、うまく行
きませんでした。
それで、この自作PCはFedora8とデュアルブートにしているので、Fedoraの方を
立ち上げ、Fedoraの/etc/X11/xorg.confを見てみました。(Fedoraの方はkernel
が新しいせいか、ビデオカードを自動認識して XWindowが立ち上がったからで
す。ーFedoraは、kernel 2.6.23.1-42.fc8)
しかし、Fedoraを参考にしても xorg.confをうまく設定できず、急いでもいまし
たので(年賀状を作成中)、ちょっと古めのビデオカードを買ってきた方が早い
と思い、MSI社製のnVidia Geforce7300LEを買ってきて、マザーボードに付けた
ところ、不十分ですが、Xが立ち上がりました。(解像度 800x600 で荒い画面で
した)
それで、Fedoraを参考にして、/etc/X11/xorg.confのSection "Screen"の部分を
以下のように変更したところ、Xがきれいに立ち上がりました。
--------------
# X.Org X11R6.9.0 configuration generated by Xconfigurator 5.03
Section "ServerLayout"
Identifier "XOrg Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/TrueType"
FontPath "unix/:7100"
FontPath "/usr/X11R6/lib/X11/fonts/japanese"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
EndSection

# Module loading section

Section "Module"
Load "dbe" # Double-buffering
Load "GLcore" # OpenGL support
Load "dri" # Direct rendering infrastructure
Load "glx" # OpenGL X protocol interface
Load "extmod" # Misc. required extensions
Load "v4l" # Video4Linux
# Load "record" # X event recorder
Load "type1" # Adobe Type 1 font handler
Load "freetype" # TrueType font handler
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
#Option "Xkbdisable"
Option "XkbRules" "xorg"
Option "XkbLayout" "jp"
Option "XkbModel" "jp106"
#Option "XkbOptions" "ctrl:nocaps"
EndSection


Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "Protocol" "IMPS/2"
Option "Emulate3Buttons" "on"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "LL-T1502A"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 24 - 61
VertRefresh 56 - 76
Option "dpms"
EndSection

Section "Device"
Identifier "nVidia Corporation G72 [GeForce 7300 LE]"
Driver "nv"
BoardName "Unknown"
EndSection

Section "Device"
Identifier "Linux Frame Buffer"
Driver "fbdev"
BoardName "Unknown"
EndSection

Section "Screen"
Identifier "Screen0"
Device "nVidia Corporation G72 [GeForce 7300 LE]"
Monitor "LL-T1502A"
DefaultDepth 8←ここを24にした
Subsection "Display"
Depth 8←ここも24にした
Modes "800x600"←ここを"1024x768"にした
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection
-------------------

Xorgのログファイルの件ですが、現在の/var/log/Xorg.0.log ファイルを見てみ
ましたが、
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Dec 29 12:22:17 2007
とあって、最初のXが設定できなかった時のログファイルがないようですので、
省略します。
とにかく現在、新しいビデオカードを付けて、XWindowが立ち上がるようになり
ました。いろいろと貴重なご助言をありがとうございました。
(本当はAopen AX33G-ULマザーボードは、ビデオカードはオンボードですから、
(Fedoraを参考にして)xorg.confを設定して Xが立ち上げればいいのですが、
何度かやってみましたが、私の実力ではうまく行かず、ビデオカードを購入した
という結末になりました。)

投稿者 xml-rpc : 2007年12月29日 13:41
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/68152
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。