2007年12月21日

[vine-users:077904] Re: LAN の自動起動

宮尾です
以下の通り確認してみました。
MACアドレスがどうも問題のような気がします。
> 起動時の状態確認
> # netstat -rn
[root@xxxxx root]# netstat -rn
カーネルIP経路テーブル
受信先サイト ゲートウェイ ネットマスク フラグ MSS Window irtt

インターフェース
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0
lo

> 起動時ネットワークのスクリプトの状態
> # /etc/init.d/network status
[root@xxxxx root]# /etc/init.d/network status
設定されたデバイス:
lo eth0
現在活動中のデバイス:
lo

> 手動でアクティブに
> # ifup eth0
> (正常だと何も無くコントロールが返ります)
[root@xxxxx root]# ifup eth0
デバイス eth0 は存在しないようですので初期化を遅らせます

> そして再び netstat と network status を実行。
[root@xxxxx root]# netstat -rn
カーネルIP経路テーブル
受信先サイト ゲートウェイ ネットマスク フラグ MSS Window irtt
インターフェース
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0
lo
[root@xxxxx root]# /etc/init.d/network status
設定されたデバイス:
lo eth0
現在活動中のデバイス:
lo

> 次に手動で停止。
> # ifdown eth0
> (正常だと何も無くコントロールが返ります)
[root@xxxxx root]# ifdown eth0
デバイス eth0 は期待と異なるMACアドレスを持っています。無視します。

> 三度、netstat と network status を実行。
[root@xxxxx root]# netstat -rn
カーネルIP経路テーブル
受信先サイト ゲートウェイ ネットマスク フラグ MSS Window irtt
インターフェース
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0
lo
[root@xxxxx root]# /etc/init.d/network status
設定されたデバイス:
lo eth0
現在活動中のデバイス:
lo

> そして スクリプトによる活性をテストします。
> # /etc/init.d/network restart (またはstart)
[root@xxxxx root]# /etc/init.d/network start
ネットワークパラメータを設定中: [ OK ]
ループバックインターフェースを活性化中: [ OK ]
インターフェース eth0を活性化中: デバイス eth0 は存在しないようですので
初期化を遅らせます
[ 失敗 ]

この様な結果が出ました。
結果からMACアドレスがどうも原因じゃないかと解ったのですが、どの様に
修復すればいいのか、解りません
ご教授下さい。

/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/

宮尾 勝巳  ( Katumi Miyao )
E-mail : miyao@xxxxx

/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/

投稿者 xml-rpc : 2007年12月21日 13:58
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/67880
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。