2005年4月19日

[vine-users:071596] rubyのバージョン

伊藤と申します。

Vine Linux 3.1に標準添付されているRubyで開発を行っていたのですが、

ruby --version

でバージョンを確認したら 1.8.2 とでていたので、このバージョンから実装さ
れたらしい String#toutf8 を使ったらそんなメソッドなんてない!というよう
なエラーがでました。

おかしいなと思い

rpm -q ruby

としてみたら 1.8.1 とでるじゃないですか!

もう一度

ruby --version

をよくみて見たところ

ruby 1.8.2 (2004-11-03) [i386-linux]

あれ? 1.8.2 のリリース日は2005-12-15のはず。

いったい、Vine Linux 3.1に標準添付されているRubyは何者なのでしょうか?

--
Asuka Ito <asuka@xxxxx>

投稿者 xml-rpc : 2005年4月19日 18:14
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/13397
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。