2005年4月 1日

[vine-users:071328] Re: Mplayer の起動でエラー 

おかげさまでインストールできました。
皆さんありがとうございました。

手順はシノバーさんのHP
http://shino.pos.to/linux/mplayer.html
に沿って作業を行ないました。
これで普通の方はすんなりと問題なくインストールできるはず
です。

しかし私は勉強不足故つまずきました。

まず、リビルドとインストールの違い、つまり、*.src.rpmと*.i386.rpm
の違いが分らず、何所からかパッケージのソースファイルをダ
ウンロードしてきてリビルドしただけでインストールしたと思
い込んでいました。
次にパッケージの依存関係を満たすにはバージョンが重要な役
割を果たす事を理解していませんでした。具体例をあげますとSDL-devel-1.2.5-0vl1.2.i386.rpm
をインストールしようとしたらSDL-1.2.5を要求されました。
そして、SDL-1.2.5-0vl1.2.i386.rpmをインストールしようと
したら"既にSDL-1.2.7がインストールされています。"とでて
きました。ここでSDL-devel-1.2.5-*.2.i386.rpmの代りにSDL-devel-1.2.7-*.i386.rpm
をダウンロードしてきてインストールすればいい事に気がつい
たのは、散々ファイルの依存関係に悩まされた後でした。

初心者にありがちな遠回りをしていました。

tora

__________________________________
Do You Yahoo!?
Upgrade Your Life
http://bb.yahoo.co.jp/


投稿者 xml-rpc : 2005年4月 1日 07:24
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/13129
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。