2005年1月19日

[vine-users:069853] Re: mplayerです

シノバーです。再送ですので重複したらゴメンナサイ

> 名古良輔 <suke@xxxxx> さん wrote:
> > Google で調べて、以下のページを参考に、Synaptic を使用してインストールし
> > ようと試みたのですが、 libpng.so.2 が必要だがインストールできない、とい
> > うようなコメント出てきて、先へ進めません。
>
On Tue, 18 Jan 2005 01:11:42 +0900
OGAWA Yuji <yu_larva_aisance@xxxxx> wrote:
> で、たぶん -devel というやつがインストールされていないはずですので

> これを入れてやれば、.so.2 ファイルが入るはずです。
> (「開発ツールが含まれない」という Vine 3.X のいつもの問題です。)

「.so」は -develですが
「.so.数字」 というのは普通 -devel ではなく本体(?)側にあります。

Vine Linux 3.1(に -develを追加したもの)で調べてみると

$ rpm -ql libpng | grep so
/usr/lib/libpng.so.3
/usr/lib/libpng.so.3.1.2.8
/usr/lib/libpng12.so.0
/usr/lib/libpng12.so.0.1.2.8

$ rpm -ql libpng-devel | grep so
/usr/lib/libpng.so
/usr/lib/libpng12.so
といった具合です。

さておき、mplayerのパッケージを入れるのに libpng.so.2 が必要ということですが、
上記のようにVine Linux 3.1ではそれがありません。
(libpng12.so.0というのがもしかすれば同じようなものなのかもしれないが)
これはVine Linux 3.1用ではないパッケージを入れようとしているからで、
この解決は Vine 3.1に無い libpng.so.2を入手するか、
Vine 3.1用のパッケージを入手あるいは作るかです。

Vine 3.1用 mplayerのnosrc.rpmは用意していますので、
これからのリビルドをお勧めします。
それなりにハードルはありますが。

# xineのほうもなかなか良いですよ

--
Masaki Shinomiya <shino@xxxxx>
http://shino.pos.to/linux/

投稿者 xml-rpc : 2005年1月19日 09:21
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/11629
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。