2004年11月26日

[vine-users:068868] Re: Vine3.1でemacsでファイルを開けない

木ノ本です。

みなさん、ありがとうございました。
私も

# apt-get install xdvik-search

で、

> An error has occurred while loading `~/.emacs.el':

>
> File error: "Cannot open load file", "xdvi-search"

のエラーが出なくなりました。

ちなみに root では上記操作をしなくてもうまくいったのは
.emacs.el の該当個所である ;; YaTeX 1.72 のところの

;; TeX source special のための設定
(require 'xdvi-search) ; 必須
(custom-set-variables
'(server-switch-hook (quote (raise-frame)))) ; 窓を上に
(custom-set-faces)
(add-hook 'yatex-mode-hook
'(lambda ()
(define-key YaTeX-mode-map "\C-c\C-j" 'xdvi-jump-to-line)))

が、一般ユーザにはあるのに root では無かったのが原因でした。
これはもしかしたら Vine3.0 をクリーンインストールした時に
私が古いバージョンの Vine から上書きコピーしてしまった
のかもしれません(既に記憶がありません)。

root の .emacs.el では ;; YaTeX 1.67 のバージョンでしたし。

--
Kinomoto, Masakazu
mailto:kinomoto@xxxxx

投稿者 xml-rpc : 2004年11月26日 19:16
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/28278
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。