2004年11月21日

[vine-users:068765] Re: xineのインストール

まちの です。

On Sun, 21 Nov 2004 16:26:26 +0900
Soji Sakamoto <soji-s@xxxxx> wrote:

> [root@xxxxx xine]# rpm -ivh *.rpm
> エラー: 依存性の欠如:
> libFLAC.so.4 は libxine1-1_rc5-ur1 に必要とされています
>
> とのメッセージが出てインストールできません。


SRPMからrebuildしないとバイナリは依存関係が異なるのでダメでしょう。
VinePlusにあるモノならば
libFLAC++.so.4 (libFLAC.so.4ではない)
だと思いますが...

> [root@xxxxx xine]# apt-get install flac
> パッケージリストを読みこんでいます... 完了
> 依存情報ツリーを作成しています... 完了
> * flac は既に最新バージョンがインストールされています。
> アップグレード: 0 個, 新規インストール: 0 個, 削除: 0 個, 保留: 0 個
>
> でますので、問題ないと思うのですが。

flacはVineのモノであれば、なおさら
xineのバイナリを作った環境のflacではないという事でしょう。
xineのsourceあるいは少なくともSRPMからのbuildを行うべきです。

# RPMのバイナリは環境依存があるので、それを構築したdistribution以外では
# 原則的には使えません。


--
まちの
machino@xxxxx
machino@xxxxx
GnuPG Fingerprint = 815A FA0C 973D AF3C C9EA 7B9B 8D84 8CD3 6B4F BF32


投稿者 xml-rpc : 2004年11月21日 17:38
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/28083
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。