2004年11月18日

[vine-users:068659] vine3.0を入れたら共存OSが起動出来なくなった(ご報告)

久しぶりの投稿になります。げんしぃ和尚です。

IBM ThinkPad X23に、WindowsXPProとVine26.r4を入れておりましたが、
空きのパーティションにVine3.0を入れてみましたところ、これまで遭遇した
ことのない状況になりました。MLにもwebにも見当たらないのでご報告です。

その状況とは、WinXPを入れたパーティションがアクティブであるにも関わらず
起動してくれないというものです。Win98の起動ディスクにて立ち上げ後、
fdiskで改めて、アクティブパーティションとして再設定してやることで直り
ました。


以下、その経緯です。もし、Vine3.0を入れて共存のOSが起動出来なくなった
場合の参考にして頂ければと思います。

/dev/hda2にWindowsXP
/dev/hda9にVine2.6r4
で、Vine2/6r4のliloは/dev/hda9に入っており、XPのローダから起動して
います。

今回は/dev/hda7にVine3.0をフルインストールしました。
liloはもちろんMBRではなく、/dev/hda7に入れました。

起動ディスクを作る為に、FDを一枚用意していたんですが、作成の操作をする
こともなく、インストールが終わってしまいました。
これじゃぁ、Vine3.0が起動出来ないなぁ、と思いながら再起動をしたところ、
「OS」が見つからないといった内容のエラーが。

起動ディスクを作る過程もなかったし、誤ってMBRを壊したのだろうかと
思い、

・Win98の起動ディスクから「fdisk /mbr」->変わらず
・WinXPのインストールCDで立ち上げ回復コンソールから「fixmbr」->変わらず
・Win98の起動ディスクから、fdiskをすると確かに/dev/hda2(c:\)が
 アクティブになっているものの、他に手段を思いつかないので、上書きでも
 する気分で、/dev/hda2(c:\)をアクティブに指定->復旧

元の環境(XPとVine2.6r4)は復旧したものの、Vine3.0が起動出来ないのは
変わらないので、起動ディスクを作成するのを選択し忘れたんだろうと、
2,3度インストールして、その度に再現しました。

Vine3.0のインストーラは何をしてくれたんでしょうかw
こんなこと初めてです。いつもどおりfdiskで/dev/hda7をext3にフォーマット
しただけなんですが・・・
テキストインストーラにバグがあるようですが、GUIベースで行いましたし。
(ウルトラベースのCDから起動しGUIインストール)

もしかしたら、win98の起動ディスクを使わなくても、vineのfdiskで/dev/hda2
をアクティブに指定すれば直るのかも知れませんが、Linuxのfdiskでやった
ことはないので、今回も試してはいません。


それと結局、Vine3.0では起動ディスクが作成されないんですね。

・Vine3.0インストール
・Win98起動ディスクで起動後、fdiskでパーティションをアクティブ化
 (表示上はアクティブになってるんだけど・・・)
・WindowsXPにてGRUBを持ってきて、GRUBの起動ディスク作成
・GRUBの起動ディスクからVine3.0を起動
・「dd if=/dev/hda7 of=bootsect.vine30 bs=512 count=1」して
 これをWinXPから見れるパーティションに保存
・WinXP起動後、bopt.ini中で、bootsect.vine30を記載

これでようやく既存環境と共存が完了。
GRUBを使ったことが無かったので、これが手間でした。

次期の3.1では
・もし、上記のアクティブパーティションの件でバグがあるなら修正して
 欲しい。
・起動ディスクをインストーラで作成するようにして欲しい
・*-develはともかく、カーネルソースぐらいは入れて欲しい

と思いました。


以上

投稿者 xml-rpc : 2004年11月18日 15:41
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/27935
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。