2004年11月16日

[vine-users:068582] Sawfish-1.3がインストールできない

藤田と申します。

Date: Tue, Nov 16, 2004 at 01:02:58AM +0900
Subject: [vine-users:068579] Sawfish-1.3がインストールできない
Message-Id: <4198D332.8070905@xxxxx>

> こんにちは 澤田です
> Vine3.0をインストールしたのですがどうも昔のSawfishの方が使いやすかったの
> でSawfish-1.3をダウンロードしてREADMEにしたがってインストールしようとし
> ました。ところが、インストーラーが

> configure:error:can't find librep:is it installed?
> というメッセージを返してきます。
> $rpm -q librep
> librep-0.16.0.1-0v14
> 上のようにrpmコマンドで調べると確かにインストールされています。

普通コンパイルするなら *-devel というパッケージがいりそうなので、
> apt-cache search | grep librep
librep - 組込み LISP 環境
librep-devel - librep 用インクルードファイルとライブラリ
rep-gtk - librep Lisp 環境用 GTK+ バインディング
rep-gtk-gnome - librep 用 GNOME バインディング
rep-gtk-libglade - librep 用 libglade バインディング

で、
> sudo apt-get install librep-devel
> rpm -ql librep-devel | grep config
/usr/bin/rep-config
/usr/libexec/rep/i386-vine-linux/rep_config.h

で ./configure が途中まで通ります。
でも、
checking for rep-gtk >= 0.17... no
configure: error: You need rep-gtk version 0.17+
で止まります....。
Vine のパッケージでは rep-gtk は 0.15 なのでこちらからバージョンアップ
する必要がありそうです。

sawfish で何がしたいのかわかりませんが、ショートカットなら
fluxbox なども便利です。
こちらも、sawfish が無かったので、fluxbox に移行してしまいました。


投稿者 xml-rpc : 2004年11月16日 02:18
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/27817
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。