2004年11月15日

[vine-users:068569] network-adminのエラー

白鳥です。

Vine3.0を使っています。
これまで、家と大学でノートPCのネットワークの設定をgnomeのnetwork-adminを
用いて切替えて使用していました。

たまにnetwork-adminが起動しないということがあったのですが、過去ログの
[vine-users:067953] network-adminの不具合
などを参考にして、/etc/sysconfig/networkのGATEWAYDEVを直していました。し
かし先日にネットワークの

設定を変更したところ、その方法でもnetwork-adminが起動しなくなってしまい
ました。

/etc/sysconfig/networkは
NETWORKING=yes
GATEWAY=""
GATEWAYDEV=""
HOSTNAME=localhost.localdomain
となっていますが、terminalからnetwork-adminを起動しようとすると、
画面上に「バックエンド・スクリプトの実行中にエラー発生しました」というエ
ラーが表示され、terminalに
# Entity: line 302: parser error : internal error
<gatewaydev>p </gatewaydev>
^
Entity: line 302: parser error : Extra content at the end of the
document
<gatewaydev>p </gatewaydev>
^
というエラーを残して起動しません(pの後ろは半角の□のような文字)。

試しに/etc/sysconfig/networkのGATEWAYDEVを
GATEWAYDEV="eth0"
としても
<gatewaydev>p </gatewaydev>
^
と表示されてしまします。

わざと日本語を入れると
GATEWAYDEV="テスト"
とすると
<gatewaydev>てすと</gatewaydev>
^
と表示されます。

現在は、/etc/sysconfig/networkを直接いじってネットワークの切替えをしてい
るので問題はありませんが、原因がわからないのは少し気持ち悪いです。なぜ、
日本語を入れたときだけエラーメッセージが表示され、eth0と入力してもエラー
メッセージに反映されないのかもわかりません。
このような場合は、どのファイルを編集すれば起動するようになるのでしょうか。

ちなみに/etc/sysconfig/network-scripts/ifcfg-eth0は
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=static
IPADDR=192.168.1.2
NETMASK=255.255.255.0
GATEWAY=192.168.1.1
となっています。こちらのファイルのDEVICEも編集すると
/etc/sysconfig/networkと同様に日本語を入れたときだけ、エラーメッセージに
反映されます。2つのファイルを削除しても、起動しませんでした。

投稿者 xml-rpc : 2004年11月15日 09:36
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/27796
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。