2004年11月14日

[vine-users:068559] Re: configureエラーメッセージへの対応方法

太田です。

On Sun, 14 Nov 2004 20:47:18 +0900
"K.Hasegawa" <sherman@xxxxx> wrote:

> Selestia http://www.shatters.net/celestia)というソフトをインストール
> しようとするとconfigureで以下のエラーが出てしまいます。
以下のバージョン、条件で試してみました。
celestia-1.3.2.tar.gz
# ./configure --with-gtk


こっちのエラーメッセージの方が重要だと思います。
> No package 'libgnomeui-2.0' found.
パッケージ 'libgnomeui-2.0' が見つからなかったと表示されています。
必要なパッケージを調べます。
$ rpm -qf `locate libgnomeui-2.0`
libgnomeui-2.4.0.1-0vl1
libgnomeui-devel-2.4.0.1-0vl1

上記のパッケージが入っているかを確認します。
$ rpm -qa |grep libgnomeui
libgnomeui-2.4.0.1-0vl1
libgnomeui-devel-2.4.0.1-0vl1

入っていなかった場合は、上記のパッケージをインストールすれば configure
できるはずです。
# apt-get install libgnomeui-2.4.0.1-0vl1 libgnomeui-devel-2.4.0.1-0vl1

再度 configure した際に、別のパッケージがたらないとエラーが表示された場
合は同様の操作を行います。

入っていた場合は、長谷川様がお考えになった方法を試してみるのも良いかもし
れません。
> メッセージからはlibgnomeui-2.0.pcを含むディレクトリーをPKG_CONFIG_PATH
> environmentに加えなさいといっているのはわかるのですが、どうやったら
> libgnomeui-2.0.pcを含むディレクトリーが判り、その後どうすればいいのか
> 具体的な操作方法がわかりません。
libgnomeui-2.0.pc を含むディレクトリが判るためには、
find - ディレクトリ階層下のファイルを検索する。
を利用します。
# find / -name libgnomeui-2.0.pc
/usr/lib/pkgconfig/libgnomeui-2.0.pc

その後、見つかったディレクトリを環境変数 PKG_CONFIG_PATH にセットすれば
いいです。
# export PKG_CONFIG_PATH="/usr/lib/pkgconfig"

--
Kazuhiro Ota

Matsue National College of Technology
The department of information engineering
j0006@xxxxx


投稿者 xml-rpc : 2004年11月14日 21:47
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/27784
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。