2004年11月12日

[vine-users:068519] Re: gtk-1.2を必要とするアプリケーションの起動

谷村です。

興味があったので試しました。Vine3.0ですが、サンプルデータを読み込んでみま
したが正常に動作するようです。

> ./fitt: relocation error: /usr/lib/libgdk-1.2.so.0: undefined symbol:
> XListInputDevices
> というメッセージが表示させて、起動しませんでした

このようなエラーに出会ったときには、そのエラーメッセージを quote して

Googleで検索します(単語をばらばらに検索するのではなく、quoteしてまとめる
のがコツです)。試しに "undefined symbol: XListInputDevices" を検索した結
果、XListInputDeviceはどうやらlibXi.soにあるらしいことが判明しました。

あとはそれを手がかりに必要なパッケージを探せばよいと思います。

参考までに私の環境では
$ rpm -qf `locate libXi.so`
XOrg-libs-6.7.0-0vl5
XOrg-libs-6.7.0-0vl5
XOrg-devel-6.7.0-0vl5
となりました。

投稿者 xml-rpc : 2004年11月12日 12:26
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/27732
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。