2004年11月12日

[vine-users:068518] gtk-1.2を必要とするアプリケーションの起動

白鳥と申します。

現在、Vine3.0を使用しています。
以前にVine2.6r4において、以下のアプリケーションを使用していました。
Fitt : An XPS curve fitting program
http://escalab.snu.ac.kr/~berd/Fitt/fitt.html)

しかし、Vine3.0でこのアプリケーションを起動させようと
$ ./fitt とすると
./fitt: relocation error: /usr/lib/libgdk-1.2.so.0: undefined symbol:

XListInputDevices
というメッセージが表示させて、起動しませんでした
(Vine3.0は2.6r4からのアップグレードではなく、clean installで入れていま
す)。

このアプリケーションが起動しないのは、Vine3.0がgtk+-2ベースとなったこと
となにか関係があるのでしょうか。Vine2.6r4に戻せば起動できるのですが、せ
っかくVine3.0を入れたので、どなたか何か情報を知っていたら教えていただけ
ないでしょうか。


apt-getでgtk関連のものを入れて試したのですが、起動しませんでした。
とりあえず、以下のパッケージを入れたと記憶しています。
gtk2-devel, gtk+, gtk+-devel, gtk+extra, gtk+extra-devel, gtkmm, gtkmm2,
wx-gtk2, gtkhtmlなど

また関係あるかわかりませんが、自分の/usr/lib以下には
libgdk-1.2.so.0, libgdk-1.2.so.0.9.1
といったのがあります。

ソースコードからコンパイルすればいいのかなと思い、作者に問い合わせたので
すが、連絡がつかなかったので、もうメンテナンスしていなのかもしれません。
現在、他のアプリケーションを代替として使っていますが、過去にこのアプリ
ケーションで処理したデータがあり、どうにかして動作させたいのでお願いしま
す。


投稿者 xml-rpc : 2004年11月12日 05:07
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/27731
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。