2006年11月10日

[users 6975] Re: Fedora Core 6でAdobe Reader7.0.8が動きません。

expr syntax error acrobat でgoogleと結構引っかかります。

After upgrade to gtk 2.10.1, run acroread just get infinite loop of
"expr: Syntax error".with few hours work, I found a workaround:

1. open "acroread" script ,maybe in /usr/bin/,or any other path you put it;
2. find this row:
Code:


echo $mfile| sed
's/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]\)00.\([0-9]*\)\|\(.*\)/\1\2\3/g'

3. replace with:
Code:

echo $mfile| sed
's/libgtk-x11-\([0-9]*\).0.so.0.\([0-9]*\)00.\([0-9]*\)\|\(.*\)/\1\2\3/g'

http://ubuntuforums.org/showthread.php?t=233514より)

どうやら libgtk の Versionの二つ目が2桁になったのが原因らしいです。
(二つ目の * の付け忘れですね)


seijun1986@xxxxx wrote:
> Seijunと申します。お世話になっております。
>
> 雑誌についていたFedora Core 6を、Intel 865のchipsetを使ったMSIのマザーボ
> ードを使ったパソコン(CPUはCeleron2.6GHZ, AGPはnVidia FX 5200)に入れて
> みたのですが、Adobe Reader7.0.8が起動しません。
>
> ターミナルから、$ acroread &とすると、
> expr : syntax errorという文字列が限りなく表示され続けます。
> PDFを見たいのですが、何か良い手はないでしょうか。
>
> なお、SELinuxはオンにしてもオフにしても、現象は変わりません。
>
>
_______________________________________________
users mailing list
投稿先アドレス: mailto:users@xxxxx
総合案内: http://fedora.jp/mailman/listinfo/users
過去の投稿の検索: http://fedora.jp/kabayaki/

投稿者 xml-rpc : 2006年11月10日 18:45
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/49153
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。