2006年2月17日

[users 6435] Re: 他の端末からサーバーへhttp接続ができません


呂@幕張です。

確実ではありませんが、
Redhat EL2?の時代は iptablesではなく、ipchainだったかもしれません。
そちらも仕事場で利用されるマシンなので、
慎重にと・・・(私もいろんな失敗をしています:)

lsmodコマンドでカーネルにロードされているモジュールのリストを確認してみ
ましょう。

もしipchain**のようなものがリストされていれば、
/sbin/ipchains -L
とりあえず、今のルールセットを確認してみる位ですね。

あとは許可ルールを追加するか、
ipchainを無効にするかどちらかですね。

On Fri, 17 Feb 2006 17:15:16 +0900
Furuya wrote:

 > 呂様
 >
 > お世話になっております。
 >
 > 古谷です。
 >
 > ご回答をどうもありがとうございます。
 >
 > ご教授いただきました、/sbin/iptables -F を行いましたところ、
 > 下記のメッセージが表示されました。
 > 長くて申し訳ありません。
 >
 > #/sbin/iptables -F
 > /lib/modules/2.4.9-e.27/kernel/net/ipv4/netfilter/ip_tables.o:
 > init_module: Device or resource busy
 > Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters
 > /lib/modules/2.4.9-e.27/kernel/net/ipv4/netfilter/ip_tables.o: insmod /lib/modules/2.4.9-e.27/kernel/net/ipv4/netfilter/ip_tables.o failed
 > /lib/modules/2.4.9-e.27/kernel/net/ipv4/netfilter/ip_tables.o: insmod ip_tables failed
 > iptables v1.2.5: can't initialize iptables table `filter': iptables who? (do you need to insmod?)
 > Perhaps iptables or your kernel needs to be upgraded.
 > #
 >
 > まだ深い知識がないのですが、私がiptablesをloadして
 > いないということになりますでしょうか?
 >
 > FWがプロセスとして稼動しているものではないとのこと、
 > ご教授ありがとうございます。
 > FW近辺で調査をしてみます。
 >
 > 宜しくお願い致します。
 >
 >
 > On Fri, 17 Feb 2006 15:18:55 +0900
 > wrote:
 >
 > > 呂@幕張です。
 > >
 > > telnet 80で応答がないこと、それに
 > >
 > > > LinuxでFWが立ち上がっていないこと
 > >
 > > FWがかなり怪しい・・・
 > > プロセスとして動いてるものではないと認識しています。
 > >
 > > 何か根拠があるわけではないですが、
 > > 念のため/sbin/iptables -F
 > > をやってからクライアントから接続してみるとか。
 > >
 > > 呂
 > >
 > >
 > >
 > > On Fri, 17 Feb 2006 14:59:37 +0900
 > > Furuya wrote:
 > >
 > >  > いつもお世話になっております。
 > >  >
 > >  > 古谷と申します。
 > >  >
 > >  > 使用しているOSはRedHatなのですが、apacheとの関連の質問をさせて
 > >  > いただきます。
 > >  > 質問内容がこちらのMLの趣旨に合っていないようでしたら、申し訳ありません。
 > >  >
 > >  > apache_1.3.27を使用しております。
 > >  > RedHatはEnterprise ES release 2.1です。
 > >  >
 > >  > apacheをインストールしたサーバー上のブラウザは、サーバー内のコンテンツ
 > >  > Webが問題なく閲覧出来ているのですが、他の端末から閲覧することができません。
 > >  >
 > >  > httpd.confの内容では、configtestコマンドでSyntaxOKが出ることを確認してお
 > >  > ります。
 > >  >
 > >  > サーバ側で、apacheを起動し、psでプロセスが稼動していること、netstat -an
 > >  > や nmapで、port80が開いていること、LinuxでFWが立ち上がっていないこと、
 > >  > hostコマンドで他の端末が引けること等を確認しております。
 > >  >
 > >  > また、端末側からのtelnetやftp接続が可能なことや、pingでipアドレスとネー
 > >  > ムが引けていること、ブラウザでは"http://サーバIPアドレス"で接続できない
 > >  > ことを確認しています。
 > >  > telnet サーバーIPアドレス 80 では繋がらず、また、ネットワークの構造上、
 > >  > 同じHUB配下に、同仕様の他のWEBサーバが稼動しています為、ルーターで80を
 > >  > 止めていることはございません。
 > >  >
 > >  > この様な現象が起こりますのは、やはり、apacheの設定によるものでしょうか?
 > >  >
 > >  > 大変、お手数をおかけ致します。
 > >  > ご教授いただけると光栄です。
 > >  >
 > >  > 宜しくお願い申し上げます。
 > >  > _______________________________________________
 > >  > users mailing list
 > >  > users@xxxxx
 > >  > http://fedora.jp/mailman/listinfo/users
 > >
 > >
 > >
 > > _______________________________________________
 > > users mailing list
 > > users@xxxxx
 > > http://fedora.jp/mailman/listinfo/users
 >
 > --
 > 古屋 薫
 >
 > _______________________________________________
 > users mailing list
 > users@xxxxx
 > http://fedora.jp/mailman/listinfo/users

_______________________________________________
users mailing list
users@xxxxx
http://fedora.jp/mailman/listinfo/users

投稿者 xml-rpc : 2006年2月17日 17:43
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/31850
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。