2011年2月14日

[ubuntu-jp:3394]Sylpheed 3.1.0 の異常終了 (Lucid, PPAインストール)

Ubuntu-jpの皆様

 寺薗です。
 Ubuntu 10.04上で、PPAのリポジトリを使って最新版のSylpheed (3.1.0)を入
れて使っているのですが、これが時折トラブルを起こすということで、ご相談で
す。

<トラブルの状況>

 突然異常終了します。
 状況としては、メールの受信中です。メールはPOPで受信しているときが主です。
 トラブルが起きた際、~/.sylpheed-2.0/sylpheed.logには、以下のような
ログが残されています。

[17:05:17] POP3> QUIT
[17:05:17] ** Gtk-CRITICAL: gtk_tree_store_get_value: assertion `VALID_ITER (iter, tree_store)' failed
[17:05:17] ** GLib-GObject-WARNING: /build/buildd/glib2.0-2.24.1/gobject/gtype.c:4177: type id `0' is invalid
[17:05:17] ** GLib-GObject-WARNING: can't peek value table for type `<invalid>' which is not currently referenced

 また、/var/log/messagesには、

Feb 14 10:16:03 XXXXXX kernel: [ 3223.099003] sylpheed[3047]: segfault at 18 ip b7358b15 sp bf803b20 error 4 in libgtk-x11-2.0.so.0.2000.1[b7130000+3cd000]
(XXXXXXはマシン名)

 と記録され、このログエントリからみた限りでは、libgtkの関連のクラッシュと
考えられます。

<発生頻度>
 平均して1日1回程度です。起動してから異常終了するまでの時間はまちまちです。

<発生するバイナリ>
 PPAからのインストールです。今のところ、ppa:ikuya-fruitsbasket/ppaと、
ppa:klaus-vormweg/ppaの2つのリポジトリからインストールしたバイナリで確認
しています。

<発生プラットホーム>
 Ubuntu 10.04 (Lucid) 32bit, 64bit両方です。


 軽く調べてみたところ、sylpheed 2.7の頃はGTK絡みのトラブルがあったよう
ですが、いまは解決されたはずです。また、最初は自分のコンピュータでのみ発
生するのかと思っていましたが、自宅のコンピュータでも、また32/64ビット両
方で発生すること、さらには違うリポジトリでビルドされたバイナリでも発生す
るということで、ご相談する次第です。

 これはSylpheed側にご相談した方がいいのかも知れませんが、まずは皆様、似
たようなエラーに遭遇されている方はいらっしゃいますでしょうか?

--
★-☆-★-☆-★-☆-★-☆-★-☆-★-☆-★- visit http://moontation.jp/ ☆-
寺薗 淳也 (Terazono, Junya)
terakinizers@xxxxx | http://www.terakin.com/


投稿者 xml-rpc : 2011年2月14日 19:37
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/101978
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。