2006年7月 5日

[ubuntu-ja-users:0413] Re: Dapperサーバでインストールしたときのコンソールの文字化け

本間と申します。

[ubuntu-ja-users:0373] で、コンソールの文字化けが解決したと報告しました
が、別のサーバを立ち上げると、/boot/grub/menu.lstのkernelオプションに
vga=771をつけても、文字化けが避けられない状態が再現してしまいました。先
のサーバでうまくいったときに、いろいろ試行錯誤したときの設定の何かが今回
の設定で抜けているのかもしれませんが、今の所、解決できていません。

http://hp.vector.co.jp/authors/VA024651/ を見て、Puttyと日本語パッチをつ
けた puttyjp.exeをWindowsで実行し、変換をUTF-8(CJK)にすれば、文字化けが
起こらないで作業できることがわかりましたが、Windowsを使わなければならな
いのがちょっと・・・

Linuxで使えるPuttyの日本語版、あるいは、他のターミナル・エミュレータが見
つかればよいのですが。何か情報をお持ちの方がいらっしゃれば、教えていただ
ければありがたいです。

因みに、vga=771を/boot/grub/menu.lstのkernelオプションに加えてブートした
とき以下のようなメッセージが出ます。

Booting 'Ubuntu, kernel 2.6.15-23-386'
root (hd0,0)
Filesystem type is ext2fs, partition type 0x83
kernel /boot/vmlinuz-2.6.15-23-386 root=/dev/hda1 ro quiet splash
vga=771 [Linux-bzImage, setup=0x1c00, size=0x15774d]
initrd /boot/initrd.img-2.6.15-23-386
[Linux-initrd @ 0xf870000, 0x66f0c6 bytes]
savedefault
boot
You passed an undefined mode number.
Press to see video modes available, to continue or
wait 30 secs video adapter: VESA VGA
Mode: COLSxROWS
0 0F00 80x25
1 0F01 80x50
2 0F02 80x43
3 0F03 80x28
4 0F05 80x30
5 0F06 80x34
6 0F07 80x60
Enter mode number or 'scan':


宜しくお願いいたします。

On Fri, 23 Jun 2006 13:58:44 +0900
HOMMA ToshiTeru wrote:

> 本間です。
>
> /boot/grub/menu.lstのkernelにvga=771をつけブートすることで、問題は解決い
> たしました。(771が何の意味かわかっていませんが ^^); ロケールはUTF-8のま
> まです。お騒がせいたしました。
>
>
> On Fri, 23 Jun 2006 13:21:37 +0900
> HOMMA ToshiTeru wrote:
>
> > 本間です。
> >
> > 先の質問で、manの場合には、man -L UTF-8
> > でOKでした。しかし、apt-getでは文字化けしているので、
> > export LANG=ja_JP.EUC-JP
> > でロケールをEUCにして、konを使ったところ、
> > apt-getでも日本語がOKになりました。
> > ところが、今度は man で次のようなエラーが
> > でて止まってしまいます。
> >
> > コマンドステータス256で終了しました:/usr/bin/zsoelim /tmp/zmanasW29r
> > | /usr/bin/tbl | /usr/bin/nroff -mandoc -Tnippon | /usr/bin/pager -s
> >
> > man -L EUC-JPでも同じエラーが出ます。
> >
> > 仕方なく、manのときにはkonを抜けるか別のコンソールで、aptのときにはkonで
> > となってしまうのですが、何ともかっこがよくない ^^);
> >
> > 何か気がついていないことがあるのだと思うのですが・・・
> >
> > それとも、やはり最初のインストールのときにデフォルトをEUC-JPのロケールに
> > すれば事足りるのでしょうか。
> >
> > アドバイスいただければありがたいです。
> >
> >
> >
> > On Fri, 23 Jun 2006 11:18:46 +0900
> > HOMMA ToshiTeru wrote:
> >
> > > はじめて投稿いたします、本間と申します。
> > >
> > > BreezyでUTF-8のロケールでサーバをインストールしたときに、コンソールでの
> > > マニュアルページなどの日本語表示を、
> > > modprobe vga16fb
> > > modprobe fbcon
> > > jfbterm -q
> > > で行うことができていたのですが、
> > > Dapper (Alternative)のCDでInstall a serverのメニューからサーバをインス
> > > トールした後に同じことをしても
> > > modprobe の2つのコマンドではエラーは出ないものの、 jfbterm -qの後に、
> > > Oops: Unknown frame buffer ???
> > > というエラーが出てしまいます。ロケールはUTF-8です。
> > > Breezyのときには、modprobe vga16fbの後に画面が変わったのですが、
> > > それがないので、そもそもmodprobe vga16fbが効いていないような・・・
> > >
> > > 或いは、サーバとはいえ、いっそ、ubuntu-desktop-jaのパッケージを
> > > インストールして作業した方が早いでしょうか。
> > >
> > > インストール時、言語は日本語、キーボードは106キー、Expertモードで
> > > インストールしていて、EUCのロケールも一応選んではいます。
> > >
> > > 知識不足で何が起こっているかよくわかっていないので恐縮ですが、
> > > アドバイスをいただければ大変ありがたく。
--
本間 俊光(HOMMA ToshiTeru)
E-mail: homma@xxxxx
Mobile phone: 090-2024-5345


--[PR]------------------------------------------------------------------
ミニストップファンクラブ会員募集中!メルマガ購読で毎月抽選プレゼント!
   ┌─┬─┬─┬─┬─┬─┬─┬─┬─┬─┬─┬─┬─┐
   │★│イ│オ│ン│商│品│券│プ│レ│ゼ│ン│ト│★│
   └─┴─┴─┴─┴─┴─┴─┴─┴─┴─┴─┴─┴─┘
http://ad.freeml.com/cgi-bin/ad.cgi?id=el95C
------------------------------------------------------------------[PR]--
■GMO INTERNET GROUP■ GMO INTERNET www.gmo.jp


投稿者 xml-rpc : 2006年7月 5日 11:28
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/38992
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。