2010年9月12日

[tDiary-users-talk: 0468] Re:recent_tweetのsecurity error

vetteです

2010年9月12日7:13 TADA Tadashi <t@xxxxx>:
> ただただしです。

> tmpdirのexpand_pathで発生しているのなら、これですね:
>
> http://redmine.ruby-lang.org/issues/show/3733

>
> Rubyのバグなので次のリリースを待つか、recent_tweet.rbをopen-uriを
> 使わずに書き直すしかないんですが、もしサーバのrubyに手を入れられ
> るなら、tmpdir.rbの「@@systmpdir」を「@@systmpdir.unraint」にす
> ればしのげます。

untaint でいいですよね。。。とおもってバグ報告を見に行ったら
たださんの報告だったんですね。
ext/etc/etc.cのほうが修正されていたのでsnapshotからetc.cだけ
入れ替えたら動きました。

ありがとうございました。

----------------------------------------------------------
MORIOKA Toru/森岡徹
E-mail:vette@xxxxx

_______________________________________________
tDiary-users-talk mailing list
tDiary-users-talk@xxxxx
http://lists.sourceforge.jp/mailman/listinfo/tdiary-users-talk


投稿者 xml-rpc : 2010年9月12日 12:59
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/98309
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。