2006年2月22日

[selinux-users:01436] Re: LIDS について

面@LIDSの人です。

連絡が遅くなってしまいまして申し訳ないです。
先程、CONFIG_CRYPTO_SHA256=yにしたカーネルをアップロードしました。
#今まで公開されていたカーネルを入れ換えました。

On Mon, Feb 20, 2006 at 11:22:49PM +0900, Kazuki Omo wrote:
> 面@LIDSの人です。

>
> #SoftwareDesign3月号-5月号で、LIDSのミニ連載をやってます(^^)
>
> CentOSのrpm版のカーネルでは、CONFIG_CRYPTO_SHA256=mにしています。
> 理由は、「特に理由は無いですが、LIDSを組み込む以外には、なるべく
> デフォルトのCONFIGを変えたくなかったから」というだけです。
>
> LIDSでは、LFSやステートの変更などでパスフレーズを入力しますが、この際に
> SHA256のモジュールが必要になります。
>
> モジュールをロードしてしまってからPOSTBOOTステートに切替えるように
> すれば問題ないと思っていますが(そうじゃないとlidsadmコマンドで
> パスワードを入力しても、モジュールがロードできないのでエラーになる)、
> rc.localに
> modprobe sha256
> という行を加えておけば、LIDSのロード後に自動的にモジュールのロードを
> 行ってくれます。
>
> ちなみに、日経Linuxの2005年2月号〜2005年9月号に掛けてLIDSの連載を
> していましたので、そこでもRPMの使い方について詳しく触れています。
> もし御手元にあれば、参考になさってください。
>
> とりあえず、特に理由もなくモジュールにしていただけですので、
> インストール時の手間を省くためにRPMの方で
> CONFIG_CRYPTO_SHA256=y
> に直したものを上げておきます。
> #makeする環境が手元に無いので、明日の夜になると思います。
>
> On Mon, Feb 20, 2006 at 05:06:48PM +0900, onbi_xyz@xxxxx wrote:
> > いで@LIDS初心者です
> >
> > SoftWare3月号を見ながらLIDS徹底活用に挑戦しています。
> >
> > 再度、素のCentOSにrpm版のLIDSをインストールしていますが
> > 、
> > このとき/boot以下のconfig-2.6.9-22.0.2.EL_lids_2.2.2の中
> > をみるとCONFIG_CRYPTO_SHA256=mなのですが、これはソースの
> > 時と同様にインストール前にCONFIG_CRYPTO_SHA256=yにしなけ
> > ればだめなのでしょうか。
> >
> > 教えていただければ幸いです。よろしくお願いします。
> >
> > --------------------------------------
> > GANBARE! NIPPON!
> > Yahoo! JAPAN JOC OFFICIAL INTERNET PORTAL SITE PARTNER
> > http://pr.mail.yahoo.co.jp/ganbare-nippon/
> >
> >
>
> --
> Kazuki Omo: omok@xxxxx
> LIDS Japanese Information:
> Japanese: http://www.selinux.gr.jp/LIDS-JP/index.html
> English: http://www.selinux.gr.jp/LIDS-JP/LIDS_en/index.html
>
>

--
Kazuki Omo: omok@xxxxx
LIDS Japanese Information:
Japanese: http://www.selinux.gr.jp/LIDS-JP/index.html
English: http://www.selinux.gr.jp/LIDS-JP/LIDS_en/index.html

投稿者 xml-rpc : 2006年2月22日 15:16
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/32025
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。