2009年8月18日

[samba-jp:20806] Re:Samba 3.4.0をCentOS 5.3でコンパイルするとエラー

さとうさん

お世話になります、吉原です。アドバイス有難う御座います。

> 自力で RPM パッケージングやりたいなら、filter-requires-samba.sh が
> 何をやっているかぐらい把握(勉強)したほうがいいですよ。
> filter-requires-samba.sh は、生成するパッケージの依存関係から
> 該当 Perl モジュールへの依存を排除するものなので、インストール

> する必要はないものです。(面倒なので詳しい説明はパス。:-X)
>
> で、ビルドしたパッケージが /usr/local/bin/perl に依存してしまう
> 問題ですが、rpmbuild(8) を実行するときの環境変数 PATH をちゃんと
> 設定 (/usr/local/bin を削除するか優先順位を下げる)すれば、解決すると
> 思います。例えば:
>
> # PATH=/usr/sbin:/usr/bin:/sbin:/bin" rpmbuild -bb samba.spec
>
> とか。これで代わりに /usr/bin/perl に依存するようになるかと。
>
> 大したこと書いてありませんが、ご参考まで:
>
> http://www.sfo.jp/blog/archives/2007/05/cleanroom.html
>
> # 会社のビルド環境はラッパースクリプト「osstech-rpmbuild」を
> # 用意して、同等 + αのことをしています。

上記の件、仰る通り、filter-requires-samba.shの記載内容への考察が不足していま
した。
確かにgrep -vが実行されているので、依存関係を排するものだというのは改めて認

出来ました。

また、環境変数の重要性はご紹介頂いたサイトを拝見及び今回の件に直面するまで
思い至らず、改めて大変勉強になりました。

間もなくSamba 3.4.1が出るということなのでそれを待つのも手かとは思いますが、
まずは現在の環境でご案内頂いた方法Samba 3.4.0のsmb-clientまでインストール
出来るか試して動作確認してみようと思います。まずは有難う御座いました。

宜しくお願い致します。

以上

吉原 隆夫


投稿者 xml-rpc : 2009年8月18日 17:02
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/87661
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。