2009年8月14日

[samba-jp:20802] Re:Samba 3.4.0をCentOS 5.3でコンパイルするとエラー

阿部しです。

On 2009/08/14, at 20:13, 吉原 隆夫 wrote:
> libtalloc.so
> libtdb.so
> libwbclient.so
>
これらのファイルはいずれも samba-common に含まれていま

すので、samba-common を先にインストールすれば大丈夫です。
RPM がきちんとしていれば、samba-common がないと警告を出
してくれるはずなんですけど、出ないという事はやっぱり spec
ファイルがいまいちなんでしょうね。

> 更に/usr/local/bin/perlにシンボリックリンクを張ってい
> るにも
> 拘わらずこちらも必要である、と表示されてしまうのですが・・・。


perl についてはちょっとわかりません。
filter-requires-samba.sh に

/usr/lib/rpm/perl.req $* | grep -E -v '(Net::LDAP|Crypt::SmbHash|CGI|
Unicode::MapUTF8)'

とあるので、この辺を当たってみてはどうでしょう?


On 2009/08/14, at 17:23, OPC oota wrote:
> うまく動かないのは事実なので、bugzilla.samba.org. に
> 投稿してみては
> いかがでしょうか。
bugzilla を使った事がなかったのでアカウントを作り中を見てみま
したけど、ちょっと要領が掴めませんでした。spec ファイル
もいまいちみたいですし、今はあまり時間を割けないので、またの
機会にしたいと思います。


投稿者 xml-rpc : 2009年8月14日 23:11
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/87521
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。