2007年12月27日

[samba-jp:19957] Re:samba-3.0.25b-1.el4_6.2になったらLDAPが使えなくなりました。

近藤です。

お世話になります。

> 実際、今問題になってるのはどこなんでしょう。
>
> 表題の通り未だLDAPとの連携が問題なのでしょうか?
> LDAPの問題は解決し、

> アクセス制限(valid usersなど)が問題なのでしょうか?
>
> 当初はLDAP連携がうまくいっていない様子とのことでしたが、
> 今回からはアクセス制限に話が移っていたので。
> まずは切り分ける為にもアクセス制限は使用せず、
> LDAPに登録しているユーザーでご確認されてみては。
>
> アクセス制限については記憶だと
> 3.0.1x(どのバージョンかは忘れた・・)では意図した動きを
> していなかったかもしれません。
> (force groupやwrite list、valid usersどれかは忘れてしまったが)
>
> 3.0.10で出来てて3.0.25にしたら今まで違う動作をしたから
> 動かないって考えているようでしたら、
> まず3.0.10ではこんな設定で
> このユーザーはアクセス可能、
> このユーザーはアクセス不能としており、
> 意図したとおりに動作していたが、
> バージョンアップしたら意図した動作と違った。
>
> などと教えていただけると解決の糸口になる気がします。

問題は、3.0.10で出来てて3.0.25になったらLDAPと連携できなく
なったということで、調査していました。
valid usersを記述しないでwrite listとread list、invalid users
で対処できれば、問題ないです。

アクセスと書込みができたのを確認したまでなので、
複数のユーザによる確認はまだです。

投稿者 xml-rpc : 2007年12月27日 15:58
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/68088
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。