2012年7月 5日

[ruby-list:48821] [ANN] test-unit-rails 1.0.2

須藤です。

test-unit-rails 1.0.2をリリースしました。

Web: http://test-unit.rubyforge.org/index.html.ja#test-unit-rails
Install: http://test-unit.rubyforge.org/index.html.ja#test-unit-rails-install

説明:


test-unit-railsはRailsでtest-unitを使うためのライブラリです。
モック機能などを使えるテストダブルライブラリRRと統合テスト用
ライブラリCapybaraも一緒にセットアップするので、すぐに高機能
なテスト環境を用意できます。

RailsはRuby 1.8に標準添付されているTest::UnitとMiniTestをサ
ポートしていますが、test-unit 2はサポートしていません。Rails
とtest-unit 2を一緒に使っても動くのは動きますが、フル機能を
使えるわけではありません。

このリリースについて:

Bundler 1.2.0.pre.1と一緒に使っても動くようになりました。
RailsとBundler 1.2.0.pre.1とtest-unit 2を一緒に使いたい場合
はこのバージョンを使ってください。

Bundler 1.2.0.pre.1に対応するため、requireするパスが変わって
います。以前は"test/unit/rails"をrequireするようになっていま
したが、このバージョンからは"test/unit/rails/test_help"を
requireしてください。もう少しだけ詳しい説明は以下を参照して
ください。
http://test-unit.rubyforge.org/index.html.ja#test-unit-rails-install

変更点は以下のとおりです。

http://test-unit.rubyforge.org/test-unit-rails/ja/file.news.html#1-0-2

1.0.2 - 2012-07-05
------------------

改良
====

* Bundler 1.2.0.pre.1対応。 [GitHub#1] [Michael D.W. Prendergastさんが報告]

感謝
====

* Michael D.W. Prendergastさん


投稿者 xml-rpc : 2012年7月 5日 22:42
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/111308
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。