2012年5月15日

[ruby-list:48753] Re: Ruby1.9.3p194をwindows-xpへのローカルインストール時のエラーについて

前川です。

なかださん、遠藤さん ありがとうございます。

> linecacheはruby本体の内部構造を直接いじるので、ruby内部用のヘッダファ
> イルが必要です。ruby_core_sourceというgemになっていますが、linecache19
> はこれに依存しているはずです。

linecache19-0.5.13.gem は、193p0にデバッガ関連のgemをインストールするとき

http://rubyforge.org/frs/?group_id=8883 から、ダウンロードしたものですか
ら、

Ruby1.9.3p0 以外には、使用できないということですね。

ruby193p194にデバッガ関連をインストールすることは、あきらめます。

お騒がせしました。

難しいですね。

1.9.3p0→1.9.3p194にあがったら、以前のgemファイルは使えなくなる・・・

Nobuyoshi Nakada <nobu.nakada@xxxxx> wrote on 2012/05/15 11:43:55:

> なかだです。
>
> (12/05/15 10:24), eiichi_maekawa@xxxxx wrote:
> > どうしても、linecache19-0.5.13.gem を1.9.3p194にインストールできませ
ん。
> (snip)
> > D:/Ruby193p194/bin/ruby.exe extconf.rb
--with-ruby-include=D:\Ruby193p194
> > \source\ruby-1.9.3-p194 --local
> > checking for vm_core.h... no
> > D:/Ruby193p194/lib/ruby/gems/1.9.1/gems/ruby_core_source-0.1.
> 4/lib/ruby_core_source.rb:39:
> > Use RbConfig instead of obsolete and deprecated Config.
> > checking for vm_core.h... no
> > *** extconf.rb failed ***
>
> linecacheはruby本体の内部構造を直接いじるので、ruby内部用ののヘッダファ
> イルが必要です。ruby_core_sourceというgemになっていますが、linecache19
> はこれに依存しているはずです。
>
> --
> --- 僕の前にBugはない。
> --- 僕の後ろにBugはできる。
> 中田 伸悦
>
>
> ====

投稿者 xml-rpc : 2012年5月15日 14:00
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/110606
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。