2012年5月15日

[ruby-list:48752] Re: Ruby1.9.3p194をwindows-xpへのローカルインストール時のエラーについて

なかだです。

(12/05/15 10:24), eiichi_maekawa@xxxxx wrote:
> どうしても、linecache19-0.5.13.gem を1.9.3p194にインストールできません。
(snip)
> D:/Ruby193p194/bin/ruby.exe extconf.rb --with-ruby-include=D:\Ruby193p194
> \source\ruby-1.9.3-p194 --local
> checking for vm_core.h... no

> D:/Ruby193p194/lib/ruby/gems/1.9.1/gems/ruby_core_source-0.1.4/lib/ruby_core_source.rb:39:
> Use RbConfig instead of obsolete and deprecated Config.
> checking for vm_core.h... no
> *** extconf.rb failed ***

linecacheはruby本体の内部構造を直接いじるので、ruby内部用ののヘッダファ
イルが必要です。ruby_core_sourceというgemになっていますが、linecache19
はこれに依存しているはずです。

--
--- 僕の前にBugはない。
--- 僕の後ろにBugはできる。
中田 伸悦


投稿者 xml-rpc : 2012年5月15日 11:43
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/110605
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。