2012年5月15日

[ruby-list:48750] Re: Ruby1.9.3p194をwindows-xpへのローカルインストール時のエラーについて

前川です。

どうしても、linecache19-0.5.13.gem を1.9.3p194にインストールできません。

1.9.3p0では、まったく問題なくインストールできたのですが。

O/Sは、WINDOWS-XPです。rubyは、mingw版 devkitは、インストール済みで
す。


Results logged to
D:/Ruby193p194/lib/ruby/gems/1.9.1/gems/linecache19-0.5.13/ext/trace_nums/gem_make.out

を見ると、以下のメッセージでした。

D:/Ruby193p194/bin/ruby.exe extconf.rb --with-ruby-include=D:\Ruby193p194
\source\ruby-1.9.3-p194 --local
checking for vm_core.h... no
D:/Ruby193p194/lib/ruby/gems/1.9.1/gems/ruby_core_source-0.1.4/lib/ruby_core_source.rb:39:
Use RbConfig instead of obsolete and deprecated Config.
checking for vm_core.h... no
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

どのようなオプションを使用すればよいでしょうか。

よろしくお願いします。

> 前川です。
>
> linecache19-0.5.13\ext\trace_nums の mkmf.log の内容が、以下でした。
> どのように対応したら、良いでしょうか?
> よろしくお願いします。
>
>
> mkmf.logの内容
>
> have_header: checking for vm_core.h... -------------------- no
>
> "gcc -o conftest -ID:/Ruby193p194/include/ruby-1.9.1/i386-mingw32
> -ID:/Ruby193p194/include/ruby-1.9.1/ruby/backward
> -ID:/Ruby193p194/include/ruby-1.9.1 -I. -ID:\Ruby193p194\source
> \ruby-1.9.3-p194 -DFD_SETSIZE=32767 -DFD_SETSIZE=32767 -O3
> -fno-omit-frame-pointer -ggdb -Wextra -Wno-unused-parameter
> -Wno-parentheses -Wno-long-long -Wno-missing-field-initializers
> -Wpointer-arith -Wwrite-strings -Wdeclaration-after-statement
> -Wimplicit-function-declaration conftest.c -L. -LD:/Ruby193p194/lib -L.
> -lmsvcrt-ruby191 -lshell32 -lws2_32 -limagehlp "
> checked program was:
> /* begin */
> 1: #include "ruby.h"
> 2:
> 3: #include <winsock2.h>
> 4: #include <windows.h>
> 5: int main() {return 0;}
> /* end */
>
> "gcc -E -ID:/Ruby193p194/include/ruby-1.9.1/i386-mingw32
> -ID:/Ruby193p194/include/ruby-1.9.1/ruby/backward
> -ID:/Ruby193p194/include/ruby-1.9.1 -I. -ID:\Ruby193p194\source
> \ruby-1.9.3-p194 -DFD_SETSIZE=32767 -DFD_SETSIZE=32767 -O3
> -fno-omit-frame-pointer -ggdb -Wextra -Wno-unused-parameter
> -Wno-parentheses -Wno-long-long -Wno-missing-field-initializers
> -Wpointer-arith -Wwrite-strings -Wdeclaration-after-statement
> -Wimplicit-function-declaration conftest.c -o conftest.i"
> conftest.c:5:21: fatal error: vm_core.h: No such file or directory
> compilation terminated.
> checked program was:
> /* begin */
> 1: #include "ruby.h"
> 2:
> 3: #include <winsock2.h>
> 4: #include <windows.h>
> 5: #include <vm_core.h>
> /* end */
>
> --------------------
>
> have_header: checking for vm_core.h... -------------------- no
>
> "gcc -E -ID:/Ruby193p194/include/ruby-1.9.1/i386-mingw32
> -ID:/Ruby193p194/include/ruby-1.9.1/ruby/backward
> -ID:/Ruby193p194/include/ruby-1.9.1 -I.
> -ID:/Ruby193p194/include/ruby-1.9.1/ruby-1.9.3-p194 -O3
> -fno-omit-frame-pointer -ggdb -Wextra -Wno-unused-parameter
> -Wno-parentheses -Wno-long-long -Wno-missing-field-initializers
> -Wpointer-arith -Wwrite-strings -Wdeclaration-after-statement
> -Wimplicit-function-declaration conftest.c -o conftest.i"
> conftest.c:5:21: fatal error: vm_core.h: No such file or directory
> compilation terminated.
> checked program was:
> /* begin */
> 1: #include "ruby.h"
> 2:
> 3: #include <winsock2.h>
> 4: #include <windows.h>
> 5: #include <vm_core.h>
> /* end */
>
> --------------------
>
>
> "前川 映一" <eiichi_maekawa@xxxxx> wrote on 2012/05/11 11:44:07:
>
> > 前川です。
> >
> > ruby193p0 では、latest_specs.4.8.gz に関するメッセージは、ありませんで

> > た。
> >
> > ####193p0でのインストール結果##########
> >
> > D:\Ruby193p0>gem install linecache19-0.5.13.gem --
> > --with-ruby-include=D:\Ruby193p0\rubysrc-1.9.3-p0 --local
> > Temporarily enhancing PATH to include DevKit...
> > Building native extensions. This could take a while...
> > Successfully installed linecache19-0.5.13
> > 1 gem installed
> >
> > ################################
> >
> > latest_specs.4.8.gz、latest_specs.4.8.gzを解凍したフォルダ 共、ruby
ソー
> ス
> > フォルダにいれ、
> >
> > Devkitも最新を入れて、再度、実行しましたが、結果は、同じでした。
> >
> > latest_specs.4.8.gz をローカルで、インストールする方法は、ないのでしょ

> > か。
> >
> > よろしくお願いします。
> >
> > eiichi_maekawa@xxxxx wrote on 2012/05/09 15:49:39:
> >
> > >
> > > 前川です。
> > >
> > > ruby193p194を、ローカルで、設定しましたが、途中、ワーニングのエラーが

> じ
> > ま
> > > した。
> > >
> > > どのように対処すればよいでしょうか。
> > >
> > > ruby193p0では、問題なく設定できました。
> > >
> > > O/S;
> > > Microsoft Windows XP [Version 5.1.2600]
> > > (C) Copyright 1985-2001 Microsoft Corp.
> > >
> > > ******************************************************************
> > > * エラーメッセージ 193p0 では、出なかったもの
> > >
**********************************************************************
> > > D:\Ruby193p194>gem install linecache19-0.5.13.gem --
> > > --with-ruby-include=D:\Ruby193p194\source --local
> > > WARNING: Error fetching data: Errno::EHOSTUNREACH: A socket
operation
> > was
> > > attempted to an unreachable host. - connect(2)
> > >
> > > http://rubygems.org/latest_specs.4.8.gz)
> > > Temporarily enhancing PATH to include DevKit...
> > > Building native extensions. This could take a while...
> > > Successfully installed linecache19-0.5.13
> > > 1 gem installed
> > > Installing ri documentation for linecache19-0.5.13...
> > > Installing RDoc documentation for linecache19-0.5.13...
> > >
> > > D:\Ruby193p194>gem list linecache
> > >
> > > *** LOCAL GEMS ***
> > >
> > > linecache19 (0.5.13)
> > >
> > > latest_specs.4.8.gz をダウンロードし、rubyソースのフォルダに入れ
て、gem
> > > installを実行しても変わりませんでした。
> > >
> > >
> > > 設定は、すべて、ローカルで行なっています。
> > >
> > > よろしくお願いします。
> > >
> > >
> > >
> > > ====
> >
> >
> >
> > ====
>
>
>
> ====

投稿者 xml-rpc : 2012年5月15日 10:24
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/110603
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。