2011年9月10日

[ruby-list:48349] Ruby/GTK2 archlinux x64 エラー

こんにちは。ashbbです。

ruby-talkに「green shoes on archlinux x64 error...」というsubjectで
serialhexさんからpostされている問題ですが、こちらにも転送させて頂きます。

Green Shoesの問題というより、Ruby/GTK2のarchlinux x64での問題のように
見えます。何か助言を頂けると有難いです。

~~~~~
justin@xxxxx [~]$ irb
ruby-1.9.2-p290 :001 > require 'gtk2'
NameError: uninitialized constant Gdk::Drawable
from
/home/justin/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
from
/home/justin/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
from
/home/justin/.rvm/gems/ruby-1.9.2-p290/gems/gtk2-1.0.0/lib/gtk2/base.rb:25:in
`rescue in <top (required)>'
from
/home/justin/.rvm/gems/ruby-1.9.2-p290/gems/gtk2-1.0.0/lib/gtk2/base.rb:21:in
`<top (required)>'
from
/home/justin/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
from
/home/justin/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
`require'
from
/home/justin/.rvm/gems/ruby-1.9.2-p290/gems/gtk2-1.0.0/lib/gtk2.rb:11:in
`<top (required)>'
from
/home/justin/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:59:in
`require'
from
/home/justin/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:59:in
`rescue in require'
from
/home/justin/.rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:35:in
`require'
from (irb):1
from /home/justin/.rvm/rubies/ruby-1.9.2-p290/bin/irb:16:in `<main>'
~~~~~

投稿者 xml-rpc : 2011年9月10日 10:28
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/106316
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。