2011年8月12日

[ruby-list:48317] Re: WinXPでnokogiインストール

松永さん

> 試しにいまgem install nokogiriをやってみたら、以下のようになってnative
> extensionのコンパイルは実行しませんでした。OSはWin7でRubyは「ruby 1.8.7
> (2010-06-23 patchlevel 299) [i386-mingw32]」です。参考になれば。

RubyInstaller入れてみました。

Nokogiriについては,DevKitを入れなくてもインストールできました。

<ruby192,p3.1.8>Z:xml % gem install nokogiri
Fetching: nokogiri-1.5.0-x86-mingw32.gem (100%)
Successfully installed nokogiri-1.5.0-x86-mingw32
1 gem installed
Installing ri documentation for nokogiri-1.5.0-x86-mingw32...
Installing RDoc documentation for nokogiri-1.5.0-x86-mingw32...


ということは,VC2010でビルドしたRuby用のgemがないということなんでしょうかね。

なかむらさんはVC2010はお使いでなかった気がしますし,
artonさんはVC2010を使う代わりに,
必要なものについては自力でコンパイルが通るようにしておられると。

とすると,かなり無謀なことをしてた気がします。

ありがとうございました。

----
青木

投稿者 xml-rpc : 2011年8月12日 16:18
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/105707
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。