2011年8月12日

[ruby-list:48312] Re: WinXPでnokogiインストール

むらたです。

エラーログに原因が書かれていますよ。

On Friday, August 12, 2011 at 10:38 , AOKI Yoshihiro wrote:
> You have to install development tools first.

とあるように、コンパイラにパスが通ってないから発見できないのでしょう。


mswin32_100 ということは Visual Studio 2010 の何れかのエディションを
ご使用なんだと思います。そうであれば、gem install する前に vsvars32.bat
を実行して環境変数を準備する必要がありますよね。


もし、vsvars32.bat は実行してパスは通してあるのにエラーになるという事でしたら、

> Gem files will remain installed in c:/PROGRA~1/ruby/lib/ruby/gems/1.9.1/gems/nokogiri-1.5.0 for insp
> ection.
> Results logged to c:/PROGRA~1/ruby/lib/ruby/gems/1.9.1/gems/nokogiri-1.5.0/ext/nokogiri/gem_make.out

ここで提示されているログファイルの中身を見て、適切に対応すると良いです。

--
Kenta Murata
Sent with Sparrow http://www.sparrowmailapp.com)


投稿者 xml-rpc : 2011年8月12日 14:37
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/105702
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。