2011年8月 8日

[ruby-list:48271] Re: Ruby1.9.2 p290 MySQLアクセス用DBI、DBD、deprecated.gemファイル、mysql-2.8.1-x86-mswin32.gemファイルについて

前川さん

信岡です。
[ruby-list:48266] で 「DBD-Mysql を見つけられていないのではないか」 と言いましたが、
DBI や DBD-Mysql のソースコードを軽く見てみた感じだと、mysql (gem) を require する
ところで 「RubyGem version error: mysql(2.8.1 not >= 0)」 というエラーが発生している
ように思いました。
[ruby-list:48267] で、別のバージョンを試そうとしているようですが、

以下のように mysql の require をしてみて、そのときにどんなエラーが発生するのか、
どうやれば解消できるのかを調べたほうが良いような気がします。
(多分 lib/rubygems.rb あたりを調べることになると思います。)

# mysql 単体を require してみる
require 'mysql'
# require 'dbi' や require 'dbd-mysql' はせずに

--
信岡 ゆう (NOBUOKA Yu)


投稿者 xml-rpc : 2011年8月 8日 10:48
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/105541
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。