2011年8月 5日

[ruby-list:48261] Re: require 'dbi' の警告について

いろいろありがとうございます。

すみません。
gem uninstall deprecatedをして、
gem install deprecated --version=2.0.1
を実行してみましたが、変わりありませんでした。
最新の3以降をいれてみましたら、たくさんエラーが出ましたのですぐやめました。

警告が出るのですが、使えています。
それで、
ただ、
$irb
> require 'dbi'
としたら、
/usr/local/rvm/gems/ruby-1.9.2-p290/gems/deprecated-2.0.1/lib/deprecated.rb:199:
warning: already initialized constant Deprecate
=> true
と表示されるので、システムのなにかが余計なことをしているのかと
想像するぐらいで、わかりません。
エディタで
/usr/local/rvm/gems/ruby-1.9.2-p290/gems/deprecated-2.0.1/lib/deprecated.rb:199:
あたりを見ましたが、何もわかりませんでした。
こういう時、トレースするコマンドでもあれば、調べられるかと思いますが、
その辺がよくわかりません。
すみません。


2011年8月5日14:08 Fumiaki Sakamoto <ua6ta6@xxxxx>:
> 坂元と申します。
>
> Ruby1.8ですが、自分も同様の警告になったことがあります。
>
> 一度、deprecatedを削除した後
>
> $gem install deprecated --version=2.0.1
>
> と私は、deprecatedのバージョン指定してインストールしたら、警告が出なくな
> りました。
> deprecatedは、最新のバージョンは、3以降です。
> もしバージョンの不整合などで、上手く動作しないのであれば、その辺を当たっ
> てみてはいかがでしょうか。
>
> 坂元 史明
> ua6ta6@xxxxx
>
>
> On Wed, 2011-08-03 at 15:47 +0900, 稲葉伸之 wrote:
>> いなばともうします。
>>
>> ubuntu 11.04 64bit環境で利用しています。
>>
>> rvm を使い、1.9.2を利用しています。
>>
>> require 'dbi'
>>
>> をしますと、
>>
>> /usr/local/rvm/gems/ruby-1.9.2-p290/gems/deprecated-2.0.1/lib/deprecated.rb:199:
>> warning: already initialized constant Deprecate
>>
>> と表示されます。
>>
>> しかし、すみませんが、何が原因と思われますでしょうか?
>> 調べてみましたが、わかりませんでした。
>>
>> なにか、余計なことをしたと思いますが...
>>
>>
>
> --
> Fumiaki Sakamoto <ua6ta6@xxxxx>
>
>
>


投稿者 xml-rpc : 2011年8月 5日 17:37
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/105530
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。