2011年8月 3日

[ruby-list:48252] Ruby1.9.2 p290 MySQLアクセス用DBI、DBD、deprecated.gemファイル、mysql-2.8.1-x86-mswin32.gemファイルについて


前川です。

Ruby1.9.2p290で、MySQLを操作しようとして、MySQL関連のgemをインストールしま
したが、

D:\Apache2.2\htdocs\ruby_prg\em_ruby\em_db>ruby dbi_mysql_connect2.rb
D:/Ruby192p290/lib/ruby/gems/1.9.1/gems/deprecated-2.0.1/lib/deprecated.rb:199:

warning: already initialized constant Deprecate
D:/Ruby192p290/lib/ruby/site_ruby/1.9.1/dbi.rb:318:in `rescue in
load_driver': Could not load driver (Could not find driver Mysql or mysql
(error: RubyGem version error: mysql(2.8.1 not >= 0) (DBI::InterfaceError)
))
from D:/Ruby192p290/lib/ruby/site_ruby/1.9.1/dbi.rb:242:in
`load_driver'
from D:/Ruby192p290/lib/ruby/site_ruby/1.9.1/dbi.rb:160:in
`_get_full_driver'
from D:/Ruby192p290/lib/ruby/site_ruby/1.9.1/dbi.rb:145:in
`connect'
from dbi_mysql_connect2.rb:6:in `<main>'

となり、データが読めません。

MySQL関連の設定は、Ruby1.9.2p180で使用したものと同じgemファイル、DBI、DBDで
す。

Ruby1.9.2p290で使用できるバージョンをご教示ください。

現在使用しているのは、

dbd-mysql-0.4.3
dbi-0.4.3
deprecated-2.0.1.gem
mysql-2.8.1-x86-mswin32.gem

です。

O/Sは、
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

Rubyのバージョンは、
C:\Documents and Settings\M118543>ruby -v
ruby 1.9.2p290 (2011-07-09) [i386-mingw32]

よろしくお願いします。

投稿者 xml-rpc : 2011年8月 3日 15:57
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/105520
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。