2011年7月22日

[ruby-list:48237] Re: rvmをrootでインストールした時の質問。

後藤と申します。

gem env

とコマンドを叩くとgemの設定一覧がでます。そのGEM_PATHのディレクトリにrailsがないのが原因だとおもいます。
rails はどこにインストールされていますか?

後藤 幸生

2011 7 22 18:03 "稲葉伸之" <nobuyuki.inaba@xxxxx>:
> 稲葉と申します。
>
> Ubuntu 11.04を利用しています。
> ruby 1.9.2を使ってみたいと思い、ネットで調べたら、RVMでインストールしたら良さそうなのでやってみました。
> しかし、
>
> Single-User Installation as a standard user (for developers)
> Multi-User installation as root (for server administrators)
>
> と言うのがあり、rootでインストールし、うまく使えています。
> そして、最近、railsを利用したいと考えて、ネットで調べてインストールしてみましたが、
> うまく使えません。
>
> 試しに、別のエリアにもうひとつUbuntu 11.04をインストールし、
> RVMを Single-User Installation as a standard userとして、インストールし、
> gem install railsを実行し、そのあと、
> rails new sample を実行したら、うまく実行してくれますが、
>
> Multi-User installationした方で、
> gem install railsを実行し、そのあと、
> rails new sample を実行したら、
>
>
/usr/local/rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems.rb:900:in
> `report_activate_error': Could not find RubyGem rails (>= 0)
> (Gem::LoadError)
> from
/usr/local/rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems.rb:248:in
> `activate'
> from
/usr/local/rvm/rubies/ruby-1.9.2-p290/lib/ruby/site_ruby/1.9.1/rubygems.rb:1276:in
> `gem'
> from /usr/local/rvm/gems/ruby-1.9.2-p290/bin/rails:18:in `<main>'
>
> と表示され、うまくゆきません。
> なにか設定がいけないと思いますが、行き詰まっています。
> Multi-User installation で利用したいと考えています。
> なにか解決策ご存知でしたら教えてください。
>

投稿者 xml-rpc : 2011年7月22日 19:32
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/105315
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。