2011年7月13日

[ruby-list:48205] Re: rails3、RUBY1.9.2、mongrel1.1.5でckeditorの利用の問題

下田と申します。

ubuntuで試してみたところ
新規Rails3アプリにmongrelとmysql2を追加して
bundleした後に、ckeditorをbundleしてみたのですが
再現しませんでした。
Gemfileは下記のようにしました
----------

gem 'mongrel', '>= 1.2.0.pre2'
gem 'mysql2'

gem 'ckeditor', '3.5.0'
----------
ubuntuなのとmongrelが1.2.0.pre2なのが違いますけど
windows固有の問題だとすると、わかりません。

でも・・・


> 2.ckeditorを利用するため、プロジェクトにckeditor3.5.4をインストール
> しました。
>   インストールに、下記問題が発生して、解決策で対応しました。
>    ?bundle install に、mongrelをrequireできない問題が発生したため、
> Gemfileからgem mongrelをコメントしました。
ckeditorを使いたいがためにウェブサーバーを削除しなければならないという
状況は明らかにおかしいと思います。

>    ?bundle install に、mysql2をインストールできないため、gem mysql2
> を gem ruby-mysql に変更しました。
ckeditorを使いたいがためにDBも削除しなければならないという
状況はますますおかしいと思います。


両エラーとも「bundle installに」と書いてありますが
ログを見たところ「monglrel起動時に」にの間違いじゃないかと思います。
bundleは本当に関係あるのですか?

Gemfileからmongrelをコメントアウトして試してみたところ
webrickでは起動しましたがmongrelでは起動しませんでした。
でもGemfileからmongrelを削除したら当たり前だと思います。

ckeditorのインストールの仕方が怪しいと思うのですが
どうやってインストールしましたか?

--
A A Name : 下田 純也 (Jun'ya Shimoda)
(o'.'o) _/ e-mail : jun-shimo@nifty.com
(> ~ <)/ Blog : http://d.hatena.ne.jp/JironBach/
Twitter: http://twitter.com/JironBach/

投稿者 xml-rpc : 2011年7月13日 17:20
役に立ちました?:
過去のフィードバック 平均:(0) 総合:(0) 投票回数:(0)
本記事へのTrackback: http://hoop.euqset.org/blog/mt-tb2006.cgi/105280
トラックバック
コメント
コメントする




画像の中に見える文字を入力してください。